summary refs log tree commit diff
path: root/nixos/modules/services/torrent/transmission.nix
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2018-03-15 22:30:56 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2018-03-15 22:30:56 +0200
commitef64208eba1a2b9052ce6d96b4539163d1aeda9f (patch)
treec4fc3d5a6b5512b0e11021e18237977440207ae1 /nixos/modules/services/torrent/transmission.nix
parent208abe9ae3f4a3ced8942ebd3419496089e06453 (diff)
parent3ab2949e1fdfb6ef18c2935ab3e72ea1f9348ef5 (diff)
downloadnixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.gz
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.bz2
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.lz
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.xz
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.tar.zst
nixlib-ef64208eba1a2b9052ce6d96b4539163d1aeda9f.zip
Merge commit '3ab2949' from staging into master
Conflicts:
	pkgs/development/compilers/llvm/6/llvm.nix
	pkgs/servers/home-assistant/component-packages.nix
Diffstat (limited to 'nixos/modules/services/torrent/transmission.nix')
-rw-r--r--nixos/modules/services/torrent/transmission.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/torrent/transmission.nix b/nixos/modules/services/torrent/transmission.nix
index dd6b585b7e23..4911a64c95d0 100644
--- a/nixos/modules/services/torrent/transmission.nix
+++ b/nixos/modules/services/torrent/transmission.nix
@@ -90,7 +90,7 @@ in
       # 1) Only the "transmission" user and group have access to torrents.
       # 2) Optionally update/force specific fields into the configuration file.
       serviceConfig.ExecStartPre = ''
-          ${pkgs.stdenv.shell} -c "mkdir -p ${homeDir} ${settingsDir} ${fullSettings.download-dir} ${fullSettings.incomplete-dir} && chmod 770 ${homeDir} ${settingsDir} ${fullSettings.download-dir} ${fullSettings.incomplete-dir} && rm -f ${settingsDir}/settings.json && cp -f ${settingsFile} ${settingsDir}/settings.json"
+          ${pkgs.runtimeShell} -c "mkdir -p ${homeDir} ${settingsDir} ${fullSettings.download-dir} ${fullSettings.incomplete-dir} && chmod 770 ${homeDir} ${settingsDir} ${fullSettings.download-dir} ${fullSettings.incomplete-dir} && rm -f ${settingsDir}/settings.json && cp -f ${settingsFile} ${settingsDir}/settings.json"
       '';
       serviceConfig.ExecStart = "${pkgs.transmission}/bin/transmission-daemon -f --port ${toString config.services.transmission.port}";
       serviceConfig.ExecReload = "${pkgs.coreutils}/bin/kill -HUP $MAINPID";