summary refs log tree commit diff
path: root/nixos/modules/services/system/nscd.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-05-13 16:22:53 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-05-13 16:23:36 +0200
commitfc8011ad8d23411bcb950b03c80bd5ceb56c068c (patch)
treec1210f420f40901a44582ced32ca0a8fd93224bb /nixos/modules/services/system/nscd.nix
parentcb6b9c52aafa720067f9a35c360b8fee89f8332f (diff)
downloadnixlib-fc8011ad8d23411bcb950b03c80bd5ceb56c068c.tar
nixlib-fc8011ad8d23411bcb950b03c80bd5ceb56c068c.tar.gz
nixlib-fc8011ad8d23411bcb950b03c80bd5ceb56c068c.tar.bz2
nixlib-fc8011ad8d23411bcb950b03c80bd5ceb56c068c.tar.lz
nixlib-fc8011ad8d23411bcb950b03c80bd5ceb56c068c.tar.xz
nixlib-fc8011ad8d23411bcb950b03c80bd5ceb56c068c.tar.zst
nixlib-fc8011ad8d23411bcb950b03c80bd5ceb56c068c.zip
Ensure that nscd, sshd are created as system users
c0f70b4694bb2be1c25ef0e23e3f11f9d718d162 removed the fixed uid
assignment, but then it becomes necessary to set isSystemUser.

http://hydra.nixos.org/build/22182588
Diffstat (limited to 'nixos/modules/services/system/nscd.nix')
-rw-r--r--nixos/modules/services/system/nscd.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nixos/modules/services/system/nscd.nix b/nixos/modules/services/system/nscd.nix
index caedc2e42173..3c0d2043ed5d 100644
--- a/nixos/modules/services/system/nscd.nix
+++ b/nixos/modules/services/system/nscd.nix
@@ -42,7 +42,10 @@ in
 
   config = mkIf cfg.enable {
 
-    users.extraUsers.nscd.description = "Name service cache daemon user";
+    users.extraUsers.nscd =
+      { isSystemUser = true;
+        description = "Name service cache daemon user";
+      };
 
     systemd.services.nscd =
       { description = "Name Service Cache Daemon";