summary refs log tree commit diff
path: root/nixos/modules/services/system/kerberos.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-05-05 14:58:51 -0400
committerShea Levy <shea@shealevy.com>2014-07-02 12:28:18 -0400
commitb3cfb9084b3860852581be235aea90540a5302d4 (patch)
tree06cf1333ae7d60f25bd23866dbaec17b148a15dd /nixos/modules/services/system/kerberos.nix
parent80709b141ca82d5afe3874f50b822db3409bed4e (diff)
downloadnixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.gz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.bz2
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.lz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.xz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.zst
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.zip
Get all lib functions from lib, not pkgs.lib, in modules
Diffstat (limited to 'nixos/modules/services/system/kerberos.nix')
-rw-r--r--nixos/modules/services/system/kerberos.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/services/system/kerberos.nix b/nixos/modules/services/system/kerberos.nix
index 8fb5debd20e4..3a0171ca1b9b 100644
--- a/nixos/modules/services/system/kerberos.nix
+++ b/nixos/modules/services/system/kerberos.nix
@@ -1,8 +1,8 @@
-{pkgs, config, ...}:
+{pkgs, config, lib, ...}:
 
 let
 
-  inherit (pkgs.lib) mkOption mkIf singleton;
+  inherit (lib) mkOption mkIf singleton;
 
   inherit (pkgs) heimdal;
 
@@ -36,7 +36,7 @@ in
     environment.systemPackages = [ heimdal ];
 
     services.xinetd.enable = true;
-    services.xinetd.services = pkgs.lib.singleton
+    services.xinetd.services = lib.singleton
       { name = "kerberos-adm";
         flags = "REUSE NAMEINARGS";
         protocol = "tcp";