summary refs log tree commit diff
path: root/nixos/modules/services/search/solr.nix
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2014-04-03 22:46:45 +0200
committerDomen Kožar <domen@dev.si>2014-04-03 22:46:45 +0200
commit52fbaee8d753ca87c8d6439256e044633ecabe4b (patch)
treed3f8f626b67a28376c635650b10710a49c6f61a6 /nixos/modules/services/search/solr.nix
parent6e086caa8aca6c5d90bc32536efd705a674ecd10 (diff)
downloadnixlib-52fbaee8d753ca87c8d6439256e044633ecabe4b.tar
nixlib-52fbaee8d753ca87c8d6439256e044633ecabe4b.tar.gz
nixlib-52fbaee8d753ca87c8d6439256e044633ecabe4b.tar.bz2
nixlib-52fbaee8d753ca87c8d6439256e044633ecabe4b.tar.lz
nixlib-52fbaee8d753ca87c8d6439256e044633ecabe4b.tar.xz
nixlib-52fbaee8d753ca87c8d6439256e044633ecabe4b.tar.zst
nixlib-52fbaee8d753ca87c8d6439256e044633ecabe4b.zip
solr: add extraJars option
Diffstat (limited to 'nixos/modules/services/search/solr.nix')
-rw-r--r--nixos/modules/services/search/solr.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/nixos/modules/services/search/solr.nix b/nixos/modules/services/search/solr.nix
index a79b1194c80e..a1567c535d9f 100644
--- a/nixos/modules/services/search/solr.nix
+++ b/nixos/modules/services/search/solr.nix
@@ -23,6 +23,10 @@ let
       ln -s ${pkgs.ant}/lib/ant/lib/ant.jar $out/lib/
       ln -s ${cfg.solrPackage}/lib/ext/* $out/lib/
       ln -s ${pkgs.openjdk}/lib/openjdk/lib/tools.jar $out/lib/
+    '' + optionalString (cfg.extraJars != []) ''
+      for f in ${concatStringsSep " " cfg.extraJars}; do
+         cp $f $out/lib
+      done
     '';
   };
 
@@ -54,6 +58,14 @@ in {
         '';
       };
 
+      extraJars = mkOption {
+        type = types.listOf types.path;
+        default = [];
+        description = ''
+          List of paths pointing to jars. Jars are copied to commonLibFolder to be available to java/solr.
+        '';
+      };
+
       log4jConfiguration = mkOption {
         type = types.lines;
         default = ''