summary refs log tree commit diff
path: root/nixos/modules/services/scheduling/fcron.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 17:37:45 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 18:47:43 +0100
commit408b8b5725c3e6fff75aef772da248d3e95ff414 (patch)
tree692e3b61dbbff85cc97e3becf13a1376dea04a92 /nixos/modules/services/scheduling/fcron.nix
parentd882e1966251880240599d3c1b31e060661506ee (diff)
downloadnixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.gz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.bz2
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.lz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.xz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.zst
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.zip
Add lots of missing option types
Diffstat (limited to 'nixos/modules/services/scheduling/fcron.nix')
-rw-r--r--nixos/modules/services/scheduling/fcron.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/nixos/modules/services/scheduling/fcron.nix b/nixos/modules/services/scheduling/fcron.nix
index 95ff918eb6d7..0c0811ca6e0e 100644
--- a/nixos/modules/services/scheduling/fcron.nix
+++ b/nixos/modules/services/scheduling/fcron.nix
@@ -6,7 +6,7 @@ let
 
   cfg = config.services.fcron;
 
-  queuelen = if cfg.queuelen == "" then "" else "-q ${toString cfg.queuelen}";
+  queuelen = if cfg.queuelen == null then "" else "-q ${toString cfg.queuelen}";
 
   systemCronJobs =
     ''
@@ -34,33 +34,40 @@ in
     services.fcron = {
 
       enable = mkOption {
+        type = types.bool;
         default = false;
-        description = "Whether to enable the `fcron' daemon.";
+        description = "Whether to enable the <command>fcron</command> daemon.";
       };
 
       allow = mkOption {
+        type = types.listOf types.str;
         default = [ "all" ];
         description = ''
-          Users allowed to use fcrontab and fcrondyn (one name per line, "all" for everyone).
+          Users allowed to use fcrontab and fcrondyn (one name per
+          line, <literal>all</literal> for everyone).
         '';
       };
 
       deny = mkOption {
+        type = types.listOf types.str;
         default = [];
         description = "Users forbidden from using fcron.";
       };
 
       maxSerialJobs = mkOption {
+        type = types.int;
         default = 1;
         description = "Maximum number of serial jobs which can run simultaneously.";
       };
 
       queuelen = mkOption {
-        default = "";
-        description = "Number of jobs the serial queue and the lavg queue can contain - empty to net set this number (-q)";
+        type = types.nullOr types.int;
+        default = null;
+        description = "Number of jobs the serial queue and the lavg queue can contain.";
       };
 
       systab = mkOption {
+        type = types.lines;
         default = "";
         description = ''The "system" crontab contents.'';
       };