summary refs log tree commit diff
path: root/nixos/modules/services/scheduling/atd.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 17:37:45 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 18:47:43 +0100
commit408b8b5725c3e6fff75aef772da248d3e95ff414 (patch)
tree692e3b61dbbff85cc97e3becf13a1376dea04a92 /nixos/modules/services/scheduling/atd.nix
parentd882e1966251880240599d3c1b31e060661506ee (diff)
downloadnixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.gz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.bz2
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.lz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.xz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.zst
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.zip
Add lots of missing option types
Diffstat (limited to 'nixos/modules/services/scheduling/atd.nix')
-rw-r--r--nixos/modules/services/scheduling/atd.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/nixos/modules/services/scheduling/atd.nix b/nixos/modules/services/scheduling/atd.nix
index 8c96252668e3..c516c5889f12 100644
--- a/nixos/modules/services/scheduling/atd.nix
+++ b/nixos/modules/services/scheduling/atd.nix
@@ -17,18 +17,21 @@ in
   options = {
 
     services.atd.enable = mkOption {
+      type = types.bool;
       default = false;
       description = ''
-        Whether to enable the `at' daemon, a command scheduler.
+        Whether to enable the <command>at</command> daemon, a command scheduler.
       '';
     };
 
     services.atd.allowEveryone = mkOption {
+      type = types.bool;
       default = false;
       description = ''
-        Whether to make /var/spool/at{jobs,spool} writeable
-        by everyone (and sticky).  This is normally not needed since
-        the `at' commands are setuid/setgid `atd'.
+        Whether to make <filename>/var/spool/at{jobs,spool}</filename>
+        writeable by everyone (and sticky).  This is normally not
+        needed since the <command>at</command> commands are
+        setuid/setgid <literal>atd</literal>.
      '';
     };