summary refs log tree commit diff
path: root/nixos/modules/services/networking/vsftpd.nix
diff options
context:
space:
mode:
authorThomas Strobel <ts468@cam.ac.uk>2016-01-17 19:34:55 +0100
committerThomas Strobel <ts468@cam.ac.uk>2016-01-17 19:41:23 +0100
commita04a7272aa38ada45e694281071b720d4abbd0df (patch)
tree3cd20fafec2de8e3b5ec558461a779898b4e50ee /nixos/modules/services/networking/vsftpd.nix
parentae5ef2b00955a8b8cbcc93a6682a8275c4d5e52c (diff)
downloadnixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.gz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.bz2
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.lz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.xz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.zst
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.zip
Add missing 'type', 'defaultText' and 'literalExample' in module definitions
- add missing types in module definitions
- add missing 'defaultText' in module definitions
- wrap example with 'literalExample' where necessary in module definitions
Diffstat (limited to 'nixos/modules/services/networking/vsftpd.nix')
-rw-r--r--nixos/modules/services/networking/vsftpd.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/services/networking/vsftpd.nix b/nixos/modules/services/networking/vsftpd.nix
index 447149552f48..e7301e9ef5f5 100644
--- a/nixos/modules/services/networking/vsftpd.nix
+++ b/nixos/modules/services/networking/vsftpd.nix
@@ -120,7 +120,9 @@ in
       };
 
       userlistFile = mkOption {
+        type = types.path;
         default = pkgs.writeText "userlist" (concatMapStrings (x: "${x}\n") cfg.userlist);
+        defaultText = "pkgs.writeText \"userlist\" (concatMapStrings (x: \"\${x}\n\") cfg.userlist)";
         description = ''
           Newline separated list of names to be allowed/denied if <option>userlistEnable</option>
           is <literal>true</literal>. Meaning see <option>userlistDeny</option>.