summary refs log tree commit diff
path: root/nixos/modules/services/networking/supplicant.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2016-09-30 09:22:49 -0400
committerShea Levy <shea@shealevy.com>2016-09-30 09:22:49 -0400
commitb692e06686fc3550f8076070780c10140e14eb0c (patch)
treece97ff3022c37ea89ca21d9bf60626d94af9d724 /nixos/modules/services/networking/supplicant.nix
parenta98dccf1e4e980092e0b833a4fd8c21624680bca (diff)
downloadnixlib-b692e06686fc3550f8076070780c10140e14eb0c.tar
nixlib-b692e06686fc3550f8076070780c10140e14eb0c.tar.gz
nixlib-b692e06686fc3550f8076070780c10140e14eb0c.tar.bz2
nixlib-b692e06686fc3550f8076070780c10140e14eb0c.tar.lz
nixlib-b692e06686fc3550f8076070780c10140e14eb0c.tar.xz
nixlib-b692e06686fc3550f8076070780c10140e14eb0c.tar.zst
nixlib-b692e06686fc3550f8076070780c10140e14eb0c.zip
supplicant: Make the device pull in the supplicant service.
The udev rule should do this. Not sure why it doesn't.

Fixes #19029.
Diffstat (limited to 'nixos/modules/services/networking/supplicant.nix')
-rw-r--r--nixos/modules/services/networking/supplicant.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/networking/supplicant.nix b/nixos/modules/services/networking/supplicant.nix
index 16c4ee7e33bb..e3107edcd7a9 100644
--- a/nixos/modules/services/networking/supplicant.nix
+++ b/nixos/modules/services/networking/supplicant.nix
@@ -34,7 +34,7 @@ let
       '';
     in
       { description = "Supplicant ${iface}${optionalString (iface=="WLAN"||iface=="LAN") " %I"}";
-        wantedBy = [ "network.target" ];
+        wantedBy = [ "network.target" ] ++ deps;
         bindsTo = deps;
         after = deps;
         before = [ "network.target" ];