summary refs log tree commit diff
path: root/nixos/modules/services/networking/radvd.nix
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2018-02-15 06:59:15 +0100
committerFranz Pletz <fpletz@fnordicwalking.de>2018-02-15 07:02:08 +0100
commit79e7f7af9a2262f8d8e6bea2b32d18f24b668a0c (patch)
tree15d7cb93c3e24b48aad24ffe2e13f188411ef63c /nixos/modules/services/networking/radvd.nix
parent672bb6b4abd27d9b2796152522b54f5b82c9f76b (diff)
downloadnixlib-79e7f7af9a2262f8d8e6bea2b32d18f24b668a0c.tar
nixlib-79e7f7af9a2262f8d8e6bea2b32d18f24b668a0c.tar.gz
nixlib-79e7f7af9a2262f8d8e6bea2b32d18f24b668a0c.tar.bz2
nixlib-79e7f7af9a2262f8d8e6bea2b32d18f24b668a0c.tar.lz
nixlib-79e7f7af9a2262f8d8e6bea2b32d18f24b668a0c.tar.xz
nixlib-79e7f7af9a2262f8d8e6bea2b32d18f24b668a0c.tar.zst
nixlib-79e7f7af9a2262f8d8e6bea2b32d18f24b668a0c.zip
radvd service: fix due to systemd upgrade
After the systemd 237 upgrade, radvd wouldn't start anymore because the
PID file cannot be written. It seems that directories in /run has to be
explicitely defined as RuntimeDirectory now. The PID file isn't needed
due to systemd, though, so it was removed along with forking and loggia
via syslog.

This fixes the ipv6 NixOS test.
Diffstat (limited to 'nixos/modules/services/networking/radvd.nix')
-rw-r--r--nixos/modules/services/networking/radvd.nix15
1 files changed, 1 insertions, 14 deletions
diff --git a/nixos/modules/services/networking/radvd.nix b/nixos/modules/services/networking/radvd.nix
index 0199502163a3..85d7f9e4a41b 100644
--- a/nixos/modules/services/networking/radvd.nix
+++ b/nixos/modules/services/networking/radvd.nix
@@ -59,24 +59,11 @@ in
 
     systemd.services.radvd =
       { description = "IPv6 Router Advertisement Daemon";
-
         wantedBy = [ "multi-user.target" ];
-
         after = [ "network.target" ];
-
-        path = [ pkgs.radvd ];
-
-        preStart = ''
-          mkdir -m 755 -p /run/radvd
-          chown radvd /run/radvd
-        '';
-
         serviceConfig =
-          { ExecStart = "@${pkgs.radvd}/sbin/radvd radvd"
-              + " -p /run/radvd/radvd.pid -m syslog -u radvd -C ${confFile}";
+          { ExecStart = "@${pkgs.radvd}/bin/radvd radvd -n -u radvd -C ${confFile}";
             Restart = "always";
-            Type = "forking";
-            PIDFile = "/run/radvd/radvd.pid";
           };
       };