summary refs log tree commit diff
path: root/nixos/modules/services/networking/prosody.nix
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2017-04-11 18:08:51 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2017-04-11 18:18:53 +0200
commit3ab45f4b369c9c741b55ddedeaac4c797dc61c04 (patch)
tree3c5e330622e42066e50ab20a6c58b9251addf863 /nixos/modules/services/networking/prosody.nix
parent54fff9ec1a9e7425926eadffada0268351536926 (diff)
downloadnixlib-3ab45f4b369c9c741b55ddedeaac4c797dc61c04.tar
nixlib-3ab45f4b369c9c741b55ddedeaac4c797dc61c04.tar.gz
nixlib-3ab45f4b369c9c741b55ddedeaac4c797dc61c04.tar.bz2
nixlib-3ab45f4b369c9c741b55ddedeaac4c797dc61c04.tar.lz
nixlib-3ab45f4b369c9c741b55ddedeaac4c797dc61c04.tar.xz
nixlib-3ab45f4b369c9c741b55ddedeaac4c797dc61c04.tar.zst
nixlib-3ab45f4b369c9c741b55ddedeaac4c797dc61c04.zip
treewide: use boolToString function
Diffstat (limited to 'nixos/modules/services/networking/prosody.nix')
-rw-r--r--nixos/modules/services/networking/prosody.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/networking/prosody.nix b/nixos/modules/services/networking/prosody.nix
index feaa007de15e..fb9c9dc67f24 100644
--- a/nixos/modules/services/networking/prosody.nix
+++ b/nixos/modules/services/networking/prosody.nix
@@ -219,7 +219,7 @@ in
 
       data_path = "/var/lib/prosody"
 
-      allow_registration = ${ if cfg.allowRegistration then "true" else "false" };
+      allow_registration = ${boolToString cfg.allowRegistration};
 
       ${ optionalString cfg.modules.console "console_enabled = true;" }
 
@@ -244,7 +244,7 @@ in
 
       ${ lib.concatStringsSep "\n" (lib.mapAttrsToList (n: v: ''
         VirtualHost "${v.domain}"
-          enabled = ${if v.enabled then "true" else "false"};
+          enabled = ${boolToString v.enabled};
           ${ optionalString (v.ssl != null) (createSSLOptsStr v.ssl) }
           ${ v.extraConfig }
         '') cfg.virtualHosts) }