summary refs log tree commit diff
path: root/nixos/modules/services/networking/nsd.nix
diff options
context:
space:
mode:
authorChristoph Hrdinka <c.github@hrdinka.at>2015-03-18 21:01:35 +0100
committerChristoph Hrdinka <c.github@hrdinka.at>2015-03-18 21:01:35 +0100
commit6db8155e379f69d97285da4cba6dc176d28238d6 (patch)
treee2a8bba4e85a0c60fdf1f9f04a244695ca1d3e42 /nixos/modules/services/networking/nsd.nix
parent2bc6af3efccec7ff6087bea7c7b1754c5d2c7393 (diff)
downloadnixlib-6db8155e379f69d97285da4cba6dc176d28238d6.tar
nixlib-6db8155e379f69d97285da4cba6dc176d28238d6.tar.gz
nixlib-6db8155e379f69d97285da4cba6dc176d28238d6.tar.bz2
nixlib-6db8155e379f69d97285da4cba6dc176d28238d6.tar.lz
nixlib-6db8155e379f69d97285da4cba6dc176d28238d6.tar.xz
nixlib-6db8155e379f69d97285da4cba6dc176d28238d6.tar.zst
nixlib-6db8155e379f69d97285da4cba6dc176d28238d6.zip
nsd: Update from 4.1.0 -> 4.1.1
Diffstat (limited to 'nixos/modules/services/networking/nsd.nix')
-rw-r--r--nixos/modules/services/networking/nsd.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/nixos/modules/services/networking/nsd.nix b/nixos/modules/services/networking/nsd.nix
index 140b7ed2da37..707bb38ec02d 100644
--- a/nixos/modules/services/networking/nsd.nix
+++ b/nixos/modules/services/networking/nsd.nix
@@ -107,6 +107,7 @@ let
     zone:
       name:         "${name}"
       zonefile:     "${stateDir}/zones/${name}"
+      ${maybeString "zonestats: "          zone.zoneStats}
       ${maybeString "outgoing-interface: " zone.outgoingInterface}
     ${forEach     "  rrl-whitelist: "      zone.rrlWhitelist}
 
@@ -270,6 +271,19 @@ let
           Use imports or pkgs.lib.readFile if you don't want this data in your config file.
         '';
       };
+
+      zoneStats = mkOption {
+        type        = types.nullOr types.str;
+        default     = null;
+        example     = "%s";
+        description = ''
+          When config.nsd.zoneStats is set to true NSD is able of collecting
+          statistics per zone. All statistics of this zone(s) will be added
+          to the group specified by this given name. Use "%s" to use the zones
+          name as the group. The groups are output from nsd-control stats
+          and stats_noreset.
+        '';
+      };
     };
   };