summary refs log tree commit diff
path: root/nixos/modules/services/networking/notbit.nix
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-06-17 11:57:40 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-06-17 11:57:40 -0700
commit8e19ac8d7cc7018613ff51d9266dea81547df756 (patch)
tree0e8301d831813da3dcc689b5dc68c85f0623e5fc /nixos/modules/services/networking/notbit.nix
parente4316b8c17121042fd258df6df2fdbc5618c2b72 (diff)
parentd4fc2b4d99122ba6592835aa84f659b22aeea433 (diff)
downloadnixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.gz
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.bz2
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.lz
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.xz
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.zst
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.zip
Merge branch 'master.upstream' into staging.upstream
Diffstat (limited to 'nixos/modules/services/networking/notbit.nix')
-rw-r--r--nixos/modules/services/networking/notbit.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/nixos/modules/services/networking/notbit.nix b/nixos/modules/services/networking/notbit.nix
index 2e1412ff7c83..a96e181cb808 100644
--- a/nixos/modules/services/networking/notbit.nix
+++ b/nixos/modules/services/networking/notbit.nix
@@ -31,7 +31,7 @@ with lib;
     services.notbit = {
 
       enable = mkOption {
-        type = types.uniq types.bool;
+        type = types.bool;
         default = false;
         description = ''
           Enables the notbit daemon and provides a sendmail binary named `notbit-system-sendmail` for sending mail over the system instance of notbit. Users must be in the notbit group in order to send mail over the system notbit instance. Currently mail recipt is not supported.
@@ -39,13 +39,13 @@ with lib;
       };
 
       port = mkOption {
-        type = types.uniq types.int;
+        type = types.int;
         default = 8444;
         description = "The port which the daemon listens for other bitmessage clients";
       };
 
       nice = mkOption {
-        type = types.uniq types.int;
+        type = types.int;
         default = 10;
         description = "Set the nice level for the notbit daemon";
       };
@@ -65,19 +65,19 @@ with lib;
       };
 
       specifiedPeersOnly = mkOption {
-        type = types.uniq types.bool;
+        type = types.bool;
         default = false;
         description = "If true, notbit will only connect to peers specified by the peers option.";
       };
 
       allowPrivateAddresses = mkOption {
-        type = types.uniq types.bool;
+        type = types.bool;
         default = false;
         description = "If true, notbit will allow connections to to RFC 1918 addresses.";
       };
 
       noBootstrap = mkOption {
-        type = types.uniq types.bool;
+        type = types.bool;
         default = false;
         description = "If true, notbit will not bootstrap an initial peerlist from bitmessage.org servers";
       };