summary refs log tree commit diff
path: root/nixos/modules/services/networking/murmur.nix
diff options
context:
space:
mode:
authorWei-Ming Yang <rick68@users.noreply.github.com>2016-09-14 07:24:25 +0800
committerJoachim Fasting <joachifm@fastmail.fm>2016-09-23 16:08:14 +0200
commite330807e1fbd05828f5b905e9c356b803b04302e (patch)
tree557a6e8b982d0433fc61e866bb74e661d50f50f8 /nixos/modules/services/networking/murmur.nix
parentde9546307fdf8c2b34796b78791777246679124e (diff)
downloadnixlib-e330807e1fbd05828f5b905e9c356b803b04302e.tar
nixlib-e330807e1fbd05828f5b905e9c356b803b04302e.tar.gz
nixlib-e330807e1fbd05828f5b905e9c356b803b04302e.tar.bz2
nixlib-e330807e1fbd05828f5b905e9c356b803b04302e.tar.lz
nixlib-e330807e1fbd05828f5b905e9c356b803b04302e.tar.xz
nixlib-e330807e1fbd05828f5b905e9c356b803b04302e.tar.zst
nixlib-e330807e1fbd05828f5b905e9c356b803b04302e.zip
murmur service: welcome -> welcometext
fixed incorrect option name `welcome` to `welcometext`.

joachifm added a rename for backwards compat.

Closes https://github.com/NixOS/nixpkgs/pull/18570
Diffstat (limited to 'nixos/modules/services/networking/murmur.nix')
-rw-r--r--nixos/modules/services/networking/murmur.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/networking/murmur.nix b/nixos/modules/services/networking/murmur.nix
index 1cc19a2c9e09..134544cda681 100644
--- a/nixos/modules/services/networking/murmur.nix
+++ b/nixos/modules/services/networking/murmur.nix
@@ -15,7 +15,7 @@ let
     logfile=/var/log/murmur/murmurd.log
     pidfile=${cfg.pidfile}
 
-    welcome="${cfg.welcome}"
+    welcometext="${cfg.welcometext}"
     port=${toString cfg.port}
 
     ${if cfg.hostName == "" then "" else "host="+cfg.hostName}
@@ -84,7 +84,7 @@ in
         description = "Path to PID file for Murmur daemon.";
       };
 
-      welcome = mkOption {
+      welcometext = mkOption {
         type = types.str;
         default = "";
         description = "Welcome message for connected clients.";