summary refs log tree commit diff
path: root/nixos/modules/services/networking/murmur.nix
diff options
context:
space:
mode:
authorDaniel Frank <git@danielfrank.net>2018-04-10 20:27:59 +0200
committerDaniel Frank <git@danielfrank.net>2018-04-10 20:27:59 +0200
commite0de2d7ae60ee491a6bdf1389aaae49c64dea48e (patch)
tree1b630e69ff2ffe4a81f05ec1e28ac01c2f7696ec /nixos/modules/services/networking/murmur.nix
parentf28bf68bc4f93193d296718a37f94189f91ab14d (diff)
downloadnixlib-e0de2d7ae60ee491a6bdf1389aaae49c64dea48e.tar
nixlib-e0de2d7ae60ee491a6bdf1389aaae49c64dea48e.tar.gz
nixlib-e0de2d7ae60ee491a6bdf1389aaae49c64dea48e.tar.bz2
nixlib-e0de2d7ae60ee491a6bdf1389aaae49c64dea48e.tar.lz
nixlib-e0de2d7ae60ee491a6bdf1389aaae49c64dea48e.tar.xz
nixlib-e0de2d7ae60ee491a6bdf1389aaae49c64dea48e.tar.zst
nixlib-e0de2d7ae60ee491a6bdf1389aaae49c64dea48e.zip
murmur: fix /tmp usage
Diffstat (limited to 'nixos/modules/services/networking/murmur.nix')
-rw-r--r--nixos/modules/services/networking/murmur.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/services/networking/murmur.nix b/nixos/modules/services/networking/murmur.nix
index 13d7c3254f9d..873d62dbf341 100644
--- a/nixos/modules/services/networking/murmur.nix
+++ b/nixos/modules/services/networking/murmur.nix
@@ -80,7 +80,7 @@ in
 
       pidfile = mkOption {
         type = types.path;
-        default = "/tmp/murmurd.pid";
+        default = "/run/murmur/murmurd.pid";
         description = "Path to PID file for Murmur daemon.";
       };
 
@@ -252,6 +252,7 @@ in
 
       serviceConfig = {
         Type      = "forking";
+        RuntimeDirectory = "murmur";
         PIDFile   = cfg.pidfile;
         Restart   = "always";
         User      = "murmur";