summary refs log tree commit diff
path: root/nixos/modules/services/networking/minidlna.nix
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2013-12-23 21:32:13 +0100
committerPeter Simons <simons@cryp.to>2013-12-23 21:32:13 +0100
commit6bc4007e60319efbc491b8f3cfce50529459f53e (patch)
tree4de5a3a6bb65fed17da8ed8f4e080824f23556d0 /nixos/modules/services/networking/minidlna.nix
parent7bb7ea52e91fac2555dca9ccc1d99527da9fabb2 (diff)
downloadnixlib-6bc4007e60319efbc491b8f3cfce50529459f53e.tar
nixlib-6bc4007e60319efbc491b8f3cfce50529459f53e.tar.gz
nixlib-6bc4007e60319efbc491b8f3cfce50529459f53e.tar.bz2
nixlib-6bc4007e60319efbc491b8f3cfce50529459f53e.tar.lz
nixlib-6bc4007e60319efbc491b8f3cfce50529459f53e.tar.xz
nixlib-6bc4007e60319efbc491b8f3cfce50529459f53e.tar.zst
nixlib-6bc4007e60319efbc491b8f3cfce50529459f53e.zip
nixos: don't white-list port 8200 in the firewall when minidlna is enabled
If you want minidla to accept connections from the rest of the world, please
add

    networking.firewall.allowedTCPPorts = [ 8200 ];
    networking.firewall.allowedUDPPorts = [ 1900 ];

to /etc/nixos/configuration.nix.

See <http://lists.science.uu.nl/pipermail/nix-dev/2013-November/011997.html>
for the discussion that lead to this.
Diffstat (limited to 'nixos/modules/services/networking/minidlna.nix')
-rw-r--r--nixos/modules/services/networking/minidlna.nix5
1 files changed, 0 insertions, 5 deletions
diff --git a/nixos/modules/services/networking/minidlna.nix b/nixos/modules/services/networking/minidlna.nix
index e31d77f13fed..73fcb1eeea8e 100644
--- a/nixos/modules/services/networking/minidlna.nix
+++ b/nixos/modules/services/networking/minidlna.nix
@@ -55,11 +55,6 @@ in
 
   config = mkIf cfg.enable {
 
-    # Running minidlna only makes sense for serving files to the
-    # outside, so open up the required ports by default.
-    networking.firewall.allowedTCPPorts = [ port ];
-    networking.firewall.allowedUDPPorts = [ 1900 ]; # SSDP
-
     services.minidlna.config =
       ''
         port=${toString port}