summary refs log tree commit diff
path: root/nixos/modules/services/networking/btsync.nix
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2014-05-02 00:41:47 -0500
committerAustin Seipp <aseipp@pobox.com>2014-05-02 00:41:47 -0500
commitb553d116161dd9fa461d2b70328504095666c496 (patch)
tree1e48d64d385dbf50943cb5f29157fe39ec02fdee /nixos/modules/services/networking/btsync.nix
parentf21d61955897fa055cc6ac38fa73134808eb87e7 (diff)
downloadnixlib-b553d116161dd9fa461d2b70328504095666c496.tar
nixlib-b553d116161dd9fa461d2b70328504095666c496.tar.gz
nixlib-b553d116161dd9fa461d2b70328504095666c496.tar.bz2
nixlib-b553d116161dd9fa461d2b70328504095666c496.tar.lz
nixlib-b553d116161dd9fa461d2b70328504095666c496.tar.xz
nixlib-b553d116161dd9fa461d2b70328504095666c496.tar.zst
nixlib-b553d116161dd9fa461d2b70328504095666c496.zip
btsync: Default to no login/password for the Web UI
Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'nixos/modules/services/networking/btsync.nix')
-rw-r--r--nixos/modules/services/networking/btsync.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/services/networking/btsync.nix b/nixos/modules/services/networking/btsync.nix
index 898aed825913..5d0e17c293e3 100644
--- a/nixos/modules/services/networking/btsync.nix
+++ b/nixos/modules/services/networking/btsync.nix
@@ -164,6 +164,7 @@ in
       httpLogin = mkOption {
         type = types.str;
         example = "allyourbase";
+        default = "";
         description = ''
           HTTP web login username.
         '';
@@ -172,6 +173,7 @@ in
       httpPass = mkOption {
         type = types.str;
         example = "arebelongtous";
+        default = "";
         description = ''
           HTTP web login password.
         '';