summary refs log tree commit diff
path: root/nixos/modules/services/networking/btsync.nix
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2016-01-07 00:10:05 -0600
committerAustin Seipp <aseipp@pobox.com>2016-01-07 03:33:38 -0600
commit4dc7cab40ec9370816bf67b786a35679a1ebf2d1 (patch)
tree53774831a0afd303f2b290a07183fbe6950b6be2 /nixos/modules/services/networking/btsync.nix
parent90b853b70698c2b9a6ab5ce814263a417aa80bdf (diff)
downloadnixlib-4dc7cab40ec9370816bf67b786a35679a1ebf2d1.tar
nixlib-4dc7cab40ec9370816bf67b786a35679a1ebf2d1.tar.gz
nixlib-4dc7cab40ec9370816bf67b786a35679a1ebf2d1.tar.bz2
nixlib-4dc7cab40ec9370816bf67b786a35679a1ebf2d1.tar.lz
nixlib-4dc7cab40ec9370816bf67b786a35679a1ebf2d1.tar.xz
nixlib-4dc7cab40ec9370816bf67b786a35679a1ebf2d1.tar.zst
nixlib-4dc7cab40ec9370816bf67b786a35679a1ebf2d1.zip
nixos: btsync - switch to using systemd user services
Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'nixos/modules/services/networking/btsync.nix')
-rw-r--r--nixos/modules/services/networking/btsync.nix25
1 files changed, 12 insertions, 13 deletions
diff --git a/nixos/modules/services/networking/btsync.nix b/nixos/modules/services/networking/btsync.nix
index fe462aeba9cb..572a7387316b 100644
--- a/nixos/modules/services/networking/btsync.nix
+++ b/nixos/modules/services/networking/btsync.nix
@@ -83,15 +83,13 @@ in
         type = types.bool;
         default = false;
         description = ''
-          If enabled, start the Bittorrent Sync daemon. Once enabled,
-          you can interact with the service through the Web UI, or
-          configure it in your NixOS configuration. Enabling the
-          <literal>btsync</literal> service also installs a
-          multi-instance systemd unit which can be used to start
-          user-specific copies of the daemon. Once installed, you can
-          use <literal>systemctl start btsync@user</literal> to start
-          the daemon only for user <literal>user</literal>, using the
-          configuration file located at
+          If enabled, start the Bittorrent Sync daemon. Once enabled, you can
+          interact with the service through the Web UI, or configure it in your
+          NixOS configuration. Enabling the <literal>btsync</literal> service
+          also installs a systemd user unit which can be used to start
+          user-specific copies of the daemon. Once installed, you can use
+          <literal>systemctl --user start btsync</literal> as your user to start
+          the daemon using the configuration file located at
           <literal>$HOME/.config/btsync.conf</literal>.
         '';
       };
@@ -212,7 +210,9 @@ in
         default = "/var/lib/btsync/";
         example = "/var/lib/btsync/";
         description = ''
-          Where to store the bittorrent sync files.
+          Where BitTorrent Sync will store it's database files (containing
+          things like username info and licenses). Generally, you should not
+          need to ever change this.
         '';
       };
 
@@ -311,12 +311,11 @@ in
       };
     };
 
-    systemd.services."btsync@" = with pkgs; {
-      description = "Bittorrent Sync Service for %i";
+    systemd.user.services.btsync = with pkgs; {
+      description = "Bittorrent Sync user service";
       after       = [ "network.target" "local-fs.target" ];
       serviceConfig = {
         Restart   = "on-abort";
-        User      = "%i";
         ExecStart =
           "${bittorrentSync}/bin/btsync --nodaemon --config %h/.config/btsync.conf";
       };