summary refs log tree commit diff
path: root/nixos/modules/services/networking/bitlbee.nix
diff options
context:
space:
mode:
authorAnders Papitto <anderspapitto@gmail.com>2015-09-08 12:15:41 -0700
committerAnders Papitto <anderspapitto@gmail.com>2015-09-08 14:24:50 -0700
commit78f7a09e3af902f5c20639c00d72ccd9dd56a55c (patch)
treee75b8ee771daa6192bd94adc04d3f1bb807e66c8 /nixos/modules/services/networking/bitlbee.nix
parent207f74eee976330e0d99c969aa729157fab6cb0b (diff)
downloadnixlib-78f7a09e3af902f5c20639c00d72ccd9dd56a55c.tar
nixlib-78f7a09e3af902f5c20639c00d72ccd9dd56a55c.tar.gz
nixlib-78f7a09e3af902f5c20639c00d72ccd9dd56a55c.tar.bz2
nixlib-78f7a09e3af902f5c20639c00d72ccd9dd56a55c.tar.lz
nixlib-78f7a09e3af902f5c20639c00d72ccd9dd56a55c.tar.xz
nixlib-78f7a09e3af902f5c20639c00d72ccd9dd56a55c.tar.zst
nixlib-78f7a09e3af902f5c20639c00d72ccd9dd56a55c.zip
bitlbee service: enable plugins
Diffstat (limited to 'nixos/modules/services/networking/bitlbee.nix')
-rw-r--r--nixos/modules/services/networking/bitlbee.nix20
1 files changed, 15 insertions, 5 deletions
diff --git a/nixos/modules/services/networking/bitlbee.nix b/nixos/modules/services/networking/bitlbee.nix
index 27b7dd71d9e5..5e6847097a94 100644
--- a/nixos/modules/services/networking/bitlbee.nix
+++ b/nixos/modules/services/networking/bitlbee.nix
@@ -16,11 +16,12 @@ let
     ''
     [settings]
     RunMode = Daemon
-    User = bitlbee  
+    User = bitlbee
     ConfigDir = ${cfg.configDir}
     DaemonInterface = ${cfg.interface}
     DaemonPort = ${toString cfg.portNumber}
     AuthMode = ${cfg.authMode}
+    Plugindir = ${pkgs.bitlbee-plugins cfg.plugins}/lib/bitlbee
     ${lib.optionalString (cfg.hostName != "") "HostName = ${cfg.hostName}"}
     ${lib.optionalString (cfg.protocols != "") "Protocols = ${cfg.protocols}"}
     ${cfg.extraSettings}
@@ -72,7 +73,7 @@ in
             Open -- Accept connections from anyone, use NickServ for user authentication.
             Closed -- Require authorization (using the PASS command during login) before allowing the user to connect at all.
             Registered -- Only allow registered users to use this server; this disables the register- and the account command until the user identifies himself.
-        ''; 
+        '';
       };
 
       hostName = mkOption {
@@ -85,6 +86,15 @@ in
         '';
       };
 
+      plugins = mkOption {
+        type = types.listOf types.package;
+        default = [];
+        example = literalExample "[ pkgs.bitlbee-facebook ]";
+        description = ''
+          The list of bitlbee plugins to install.
+        '';
+      };
+
       configDir = mkOption {
         default = "/var/lib/bitlbee";
         type = types.path;
@@ -107,14 +117,14 @@ in
         default = "";
         description = ''
           Will be inserted in the Settings section of the config file.
-        ''; 
+        '';
       };
 
       extraDefaults = mkOption {
         default = "";
         description = ''
           Will be inserted in the Default section of the config file.
-        ''; 
+        '';
       };
 
     };
@@ -138,7 +148,7 @@ in
         gid = config.ids.gids.bitlbee;
       };
 
-    systemd.services.bitlbee = 
+    systemd.services.bitlbee =
       { description = "BitlBee IRC to other chat networks gateway";
         after = [ "network.target" ];
         wantedBy = [ "multi-user.target" ];