summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/zabbix-server.nix
diff options
context:
space:
mode:
authorLongrin Wischnewski <robberer@freakmail.de>2014-11-03 13:00:47 +0100
committerLongrin Wischnewski <robberer@freakmail.de>2014-11-03 16:47:07 +0100
commitce8e1a278b8f1717b3783e070cb3c46d8337274b (patch)
treef13979f737102863c81541c26825d2680134723b /nixos/modules/services/monitoring/zabbix-server.nix
parent512e33bcbdbed25659fdc68ec4ff03cb282515b8 (diff)
downloadnixlib-ce8e1a278b8f1717b3783e070cb3c46d8337274b.tar
nixlib-ce8e1a278b8f1717b3783e070cb3c46d8337274b.tar.gz
nixlib-ce8e1a278b8f1717b3783e070cb3c46d8337274b.tar.bz2
nixlib-ce8e1a278b8f1717b3783e070cb3c46d8337274b.tar.lz
nixlib-ce8e1a278b8f1717b3783e070cb3c46d8337274b.tar.xz
nixlib-ce8e1a278b8f1717b3783e070cb3c46d8337274b.tar.zst
nixlib-ce8e1a278b8f1717b3783e070cb3c46d8337274b.zip
zabbix-server: add extraConfig option
add types to options
Diffstat (limited to 'nixos/modules/services/monitoring/zabbix-server.nix')
-rw-r--r--nixos/modules/services/monitoring/zabbix-server.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/nixos/modules/services/monitoring/zabbix-server.nix b/nixos/modules/services/monitoring/zabbix-server.nix
index ca283ea2a99f..acd1279ddf47 100644
--- a/nixos/modules/services/monitoring/zabbix-server.nix
+++ b/nixos/modules/services/monitoring/zabbix-server.nix
@@ -32,6 +32,8 @@ let
       ${optionalString (cfg.dbPassword != "") ''
         DBPassword = ${cfg.dbPassword}
       ''}
+
+      ${config.services.zabbixServer.extraConfig}
     '';
 
   useLocalPostgres = cfg.dbServer == "localhost" || cfg.dbServer == "";
@@ -46,6 +48,7 @@ in
 
     services.zabbixServer.enable = mkOption {
       default = false;
+      type = types.bool;
       description = ''
         Whether to run the Zabbix server on this machine.
       '';
@@ -53,6 +56,7 @@ in
 
     services.zabbixServer.dbServer = mkOption {
       default = "localhost";
+      type = types.str;
       description = ''
         Hostname or IP address of the database server.
         Use an empty string ("") to use peer authentication.
@@ -61,9 +65,18 @@ in
 
     services.zabbixServer.dbPassword = mkOption {
       default = "";
+      type = types.str;
       description = "Password used to connect to the database server.";
     };
 
+    services.zabbixServer.extraConfig = mkOption {
+      default = "";
+      type = types.lines;
+      description = ''
+        Configuration that is injected verbatim into the configuration file.
+      '';
+    };
+
   };
 
   ###### implementation