summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/ups.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 11:02:04 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 14:57:42 +0100
commit862e3dd977cdd853c3ab3202ab1b73561f8a3ea1 (patch)
tree43e95414e328ac92383bccf41219c30fa9729473 /nixos/modules/services/monitoring/ups.nix
parent162b874469935923dec02cc9a6b5f58b1c8267a8 (diff)
downloadnixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.gz
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.bz2
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.lz
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.xz
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.tar.zst
nixlib-862e3dd977cdd853c3ab3202ab1b73561f8a3ea1.zip
Substitute "types.uniq types.string" -> "types.str"
Diffstat (limited to 'nixos/modules/services/monitoring/ups.nix')
-rw-r--r--nixos/modules/services/monitoring/ups.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/services/monitoring/ups.nix b/nixos/modules/services/monitoring/ups.nix
index a7b72e53f0a4..c00f4bad9351 100644
--- a/nixos/modules/services/monitoring/ups.nix
+++ b/nixos/modules/services/monitoring/ups.nix
@@ -15,7 +15,7 @@ let
       # This can be infered from the UPS model by looking at
       # /nix/store/nut/share/driver.list
       driver = mkOption {
-        type = types.uniq types.string;
+        type = types.str;
         description = ''
           Specify the program to run to talk to this UPS.  apcsmart,
           bestups, and sec are some examples.
@@ -23,7 +23,7 @@ let
       };
 
       port = mkOption {
-        type = types.uniq types.string;
+        type = types.str;
         description = ''
           The serial port to which your UPS is connected.  /dev/ttyS0 is
           usually the first port on Linux boxes, for example.
@@ -115,7 +115,7 @@ in
       # This option is not used yet.
       mode = mkOption {
         default = "standalone";
-        type = types.uniq types.string;
+        type = types.str;
         description = ''
           The MODE determines which part of the NUT is to be started, and
           which configuration files must be modified.
@@ -142,7 +142,7 @@ in
 
       schedulerRules = mkOption {
         example = "/etc/nixos/upssched.conf";
-        type = types.uniq types.string;
+        type = types.str;
         description = ''
           File which contains the rules to handle UPS events.
         '';