summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/statsd.nix
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-06-17 11:57:40 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-06-17 11:57:40 -0700
commit8e19ac8d7cc7018613ff51d9266dea81547df756 (patch)
tree0e8301d831813da3dcc689b5dc68c85f0623e5fc /nixos/modules/services/monitoring/statsd.nix
parente4316b8c17121042fd258df6df2fdbc5618c2b72 (diff)
parentd4fc2b4d99122ba6592835aa84f659b22aeea433 (diff)
downloadnixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.gz
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.bz2
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.lz
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.xz
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.tar.zst
nixlib-8e19ac8d7cc7018613ff51d9266dea81547df756.zip
Merge branch 'master.upstream' into staging.upstream
Diffstat (limited to 'nixos/modules/services/monitoring/statsd.nix')
-rw-r--r--nixos/modules/services/monitoring/statsd.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/services/monitoring/statsd.nix b/nixos/modules/services/monitoring/statsd.nix
index 7d7ca27bb2f0..d9e0b83e2389 100644
--- a/nixos/modules/services/monitoring/statsd.nix
+++ b/nixos/modules/services/monitoring/statsd.nix
@@ -37,7 +37,7 @@ in
     enable = mkOption {
       description = "Whether to enable statsd stats aggregation service";
       default = false;
-      type = types.uniq types.bool;
+      type = types.bool;
     };
 
     host = mkOption {
@@ -49,7 +49,7 @@ in
     port = mkOption {
       description = "Port that stats listens for messages on over UDP";
       default = 8125;
-      type = types.uniq types.int;
+      type = types.int;
     };
 
     mgmt_address = mkOption {
@@ -61,7 +61,7 @@ in
     mgmt_port = mkOption {
       description = "Port to run the management TCP interface on";
       default = 8126;
-      type = types.uniq types.int;
+      type = types.int;
     };
 
     backends = mkOption {