summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/prometheus/default.nix
diff options
context:
space:
mode:
authorOliver Charles <ollie@ocharles.org.uk>2017-11-17 10:16:21 +0000
committerOliver Charles <ollie@ocharles.org.uk>2017-11-17 10:16:21 +0000
commitacb7f43db94f78a7dfd1fcb507f9a78d0449639d (patch)
treea61e3390093aee84c8964612e7f60bd6a18d7280 /nixos/modules/services/monitoring/prometheus/default.nix
parentf0334c03363ae5a43028383ee7cb95edba40e239 (diff)
downloadnixlib-acb7f43db94f78a7dfd1fcb507f9a78d0449639d.tar
nixlib-acb7f43db94f78a7dfd1fcb507f9a78d0449639d.tar.gz
nixlib-acb7f43db94f78a7dfd1fcb507f9a78d0449639d.tar.bz2
nixlib-acb7f43db94f78a7dfd1fcb507f9a78d0449639d.tar.lz
nixlib-acb7f43db94f78a7dfd1fcb507f9a78d0449639d.tar.xz
nixlib-acb7f43db94f78a7dfd1fcb507f9a78d0449639d.tar.zst
nixlib-acb7f43db94f78a7dfd1fcb507f9a78d0449639d.zip
nixos/prometheus: add external_labels option
Diffstat (limited to 'nixos/modules/services/monitoring/prometheus/default.nix')
-rw-r--r--nixos/modules/services/monitoring/prometheus/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nixos/modules/services/monitoring/prometheus/default.nix b/nixos/modules/services/monitoring/prometheus/default.nix
index 2b7f88a538c1..85f39c2a43b5 100644
--- a/nixos/modules/services/monitoring/prometheus/default.nix
+++ b/nixos/modules/services/monitoring/prometheus/default.nix
@@ -66,6 +66,16 @@ let
           How frequently to evaluate rules by default.
         '';
       };
+
+      external_labels = mkOption {
+        type = types.attrsOf types.str;
+        description = ''
+          The labels to add to any time series or alerts when
+          communicating with external systems (federation, remote
+          storage, Alertmanager).
+        '';
+        default = {};
+      };
     };
   };