summary refs log tree commit diff
path: root/nixos/modules/services/monitoring/apcupsd.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2018-03-01 14:38:53 -0500
committerShea Levy <shea@shealevy.com>2018-03-01 14:38:53 -0500
commitfec543436d4d35dacde01a9e8b69a2781841f901 (patch)
treeb44b65ddbc7482e767d562f3f27c523c9ffbfcc0 /nixos/modules/services/monitoring/apcupsd.nix
parente70f61f5a19b00337082ab28a5013e0b440bda92 (diff)
downloadnixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.gz
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.bz2
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.lz
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.xz
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.zst
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.zip
nixos: Move uses of stdenv.shell to runtimeShell.
Diffstat (limited to 'nixos/modules/services/monitoring/apcupsd.nix')
-rw-r--r--nixos/modules/services/monitoring/apcupsd.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/monitoring/apcupsd.nix b/nixos/modules/services/monitoring/apcupsd.nix
index 9abd6e9ab641..839116de6265 100644
--- a/nixos/modules/services/monitoring/apcupsd.nix
+++ b/nixos/modules/services/monitoring/apcupsd.nix
@@ -38,7 +38,7 @@ let
   ];
 
   shellCmdsForEventScript = eventname: commands: ''
-    echo "#!${pkgs.stdenv.shell}" > "$out/${eventname}"
+    echo "#!${pkgs.runtimeShell}" > "$out/${eventname}"
     echo '${commands}' >> "$out/${eventname}"
     chmod a+x "$out/${eventname}"
   '';