summary refs log tree commit diff
path: root/nixos/modules/services/misc/subsonic.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-01-13 11:48:11 +0100
committerVladimír Čunát <vcunat@gmail.com>2016-01-13 12:04:31 +0100
commit3bcf8ae8795ede9909df07fb97e049442b38c231 (patch)
treee6d3a37896e3655726c2dff6946f7c37ceaa821f /nixos/modules/services/misc/subsonic.nix
parentb9f6dfe8c5c8da09b6c2d8a8e168bdcf50a0aabd (diff)
downloadnixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.gz
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.bz2
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.lz
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.xz
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.zst
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.zip
nixos manuals: bring back package references
This reverts most of 89e983786a, as those references are sanitized now.
Fixes #10039, at least most of it.

The `sane` case wasn't fixed, as it calls a *function* in pkgs to get
the default value.
Diffstat (limited to 'nixos/modules/services/misc/subsonic.nix')
-rw-r--r--nixos/modules/services/misc/subsonic.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/nixos/modules/services/misc/subsonic.nix b/nixos/modules/services/misc/subsonic.nix
index 2831e95b9480..020d53a481de 100644
--- a/nixos/modules/services/misc/subsonic.nix
+++ b/nixos/modules/services/misc/subsonic.nix
@@ -97,6 +97,7 @@ in
 
       transcoders = mkOption {
         type = types.listOf types.path;
+        default = [ "${pkgs.ffmpeg}/bin/ffmpeg" ];
         description = ''
           List of paths to transcoder executables that should be accessible
           from Subsonic. Symlinks will be created to each executable inside
@@ -152,8 +153,5 @@ in
     };
 
     users.extraGroups.subsonic.gid = config.ids.gids.subsonic;
-
-    services.subsonic.transcoders = mkDefault [ "${pkgs.ffmpeg}/bin/ffmpeg" ];
-
   };
 }