summary refs log tree commit diff
path: root/nixos/modules/services/misc/rippled.nix
diff options
context:
space:
mode:
authorJaka Hudoklin <jakahudoklin@gmail.com>2015-06-08 14:15:07 +0200
committerJaka Hudoklin <jakahudoklin@gmail.com>2015-06-08 14:15:07 +0200
commit161418537cb09440d83426ad0a0c01aa4b277ebe (patch)
tree2a37ecd44466133ce5e51ca2ad8533e96ea9f9d9 /nixos/modules/services/misc/rippled.nix
parent8b79a09f78e49fd98b713d81017a7ea8179db5d7 (diff)
downloadnixlib-161418537cb09440d83426ad0a0c01aa4b277ebe.tar
nixlib-161418537cb09440d83426ad0a0c01aa4b277ebe.tar.gz
nixlib-161418537cb09440d83426ad0a0c01aa4b277ebe.tar.bz2
nixlib-161418537cb09440d83426ad0a0c01aa4b277ebe.tar.lz
nixlib-161418537cb09440d83426ad0a0c01aa4b277ebe.tar.xz
nixlib-161418537cb09440d83426ad0a0c01aa4b277ebe.tar.zst
nixlib-161418537cb09440d83426ad0a0c01aa4b277ebe.zip
rippled: Update to 0.28.1
Diffstat (limited to 'nixos/modules/services/misc/rippled.nix')
-rw-r--r--nixos/modules/services/misc/rippled.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/nixos/modules/services/misc/rippled.nix b/nixos/modules/services/misc/rippled.nix
index 03fcc003a404..045330eb5513 100644
--- a/nixos/modules/services/misc/rippled.nix
+++ b/nixos/modules/services/misc/rippled.nix
@@ -27,7 +27,7 @@ let
     protocol=${concatStringsSep "," p.protocol}
     ${optionalString (p.user != "") "user=${p.user}"}
     ${optionalString (p.password != "") "user=${p.password}"}
-    admin=${if p.admin then "allow" else "no"}
+    admin=${concatStringsSep "," p.admin}
     ${optionalString (p.ssl.key != null) "ssl_key=${p.ssl.key}"}
     ${optionalString (p.ssl.cert != null) "ssl_cert=${p.ssl.cert}"}
     ${optionalString (p.ssl.chain != null) "ssl_chain=${p.ssl.chain}"}
@@ -118,9 +118,9 @@ let
       };
 
       admin = mkOption {
-	description = "Controls whether or not administrative commands are allowed.";
-	type = types.bool;
-	default = false;
+	description = "A comma-separated list of admin IP addresses.";
+	type = types.listOf types.str;
+	default = ["127.0.0.1"];
       };
 
       ssl = {
@@ -156,7 +156,7 @@ let
   dbOptions = {
     type = mkOption {
       description = "Rippled database type.";
-      type = types.enum ["rocksdb" "nudb" "sqlite" "hyperleveldb"];
+      type = types.enum ["rocksdb" "nudb"];
       default = "rocksdb";
     };
 
@@ -217,7 +217,7 @@ in
 	default = {
 	  rpc = {
 	    port = 5005;
-	    admin = true;
+	    admin = ["127.0.0.1"];
 	    protocol = ["http"];
 	  };