summary refs log tree commit diff
path: root/nixos/modules/services/misc/nixos-manual.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-01-13 11:48:11 +0100
committerVladimír Čunát <vcunat@gmail.com>2016-01-13 12:04:31 +0100
commit3bcf8ae8795ede9909df07fb97e049442b38c231 (patch)
treee6d3a37896e3655726c2dff6946f7c37ceaa821f /nixos/modules/services/misc/nixos-manual.nix
parentb9f6dfe8c5c8da09b6c2d8a8e168bdcf50a0aabd (diff)
downloadnixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.gz
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.bz2
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.lz
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.xz
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.tar.zst
nixlib-3bcf8ae8795ede9909df07fb97e049442b38c231.zip
nixos manuals: bring back package references
This reverts most of 89e983786a, as those references are sanitized now.
Fixes #10039, at least most of it.

The `sane` case wasn't fixed, as it calls a *function* in pkgs to get
the default value.
Diffstat (limited to 'nixos/modules/services/misc/nixos-manual.nix')
-rw-r--r--nixos/modules/services/misc/nixos-manual.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/nixos/modules/services/misc/nixos-manual.nix b/nixos/modules/services/misc/nixos-manual.nix
index 3e1f53e79f3e..2aa8f4a06cc9 100644
--- a/nixos/modules/services/misc/nixos-manual.nix
+++ b/nixos/modules/services/misc/nixos-manual.nix
@@ -80,6 +80,7 @@ in
 
     services.nixosManual.browser = mkOption {
       type = types.path;
+      default = "${pkgs.w3m-nox}/bin/w3m";
       description = ''
         Browser used to show the manual.
       '';
@@ -117,8 +118,6 @@ in
     services.mingetty.helpLine = mkIf cfg.showManual
       "\nPress <Alt-F${toString cfg.ttyNumber}> for the NixOS manual.";
 
-    services.nixosManual.browser = mkDefault "${pkgs.w3m-nox}/bin/w3m";
-
   };
 
 }