summary refs log tree commit diff
path: root/nixos/modules/services/misc/nix-gc.nix
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2016-10-23 17:26:18 +0200
committerJoachim Fasting <joachifm@fastmail.fm>2016-10-23 17:56:49 +0200
commit4c41c412a0c6353e6a49b484783b4c925064718c (patch)
treecd335693906fb15ae8638b9dd2a694a7cead4e82 /nixos/modules/services/misc/nix-gc.nix
parent645ff13a4be67718b624c5b15f316922399cc3dd (diff)
downloadnixlib-4c41c412a0c6353e6a49b484783b4c925064718c.tar
nixlib-4c41c412a0c6353e6a49b484783b4c925064718c.tar.gz
nixlib-4c41c412a0c6353e6a49b484783b4c925064718c.tar.bz2
nixlib-4c41c412a0c6353e6a49b484783b4c925064718c.tar.lz
nixlib-4c41c412a0c6353e6a49b484783b4c925064718c.tar.xz
nixlib-4c41c412a0c6353e6a49b484783b4c925064718c.tar.zst
nixlib-4c41c412a0c6353e6a49b484783b4c925064718c.zip
nix gc service: fix use of startAt
`startAt = ""` as in `startAt = optionalString false ...` results
in an invalid timer unit (due to "" being promoted to a singleton
list and not filtered out).

Ref: c9941c4b5ef7acc1cb8d734acb383410d99c01ba
Diffstat (limited to 'nixos/modules/services/misc/nix-gc.nix')
-rw-r--r--nixos/modules/services/misc/nix-gc.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/misc/nix-gc.nix b/nixos/modules/services/misc/nix-gc.nix
index 5c13da6e83dd..304168c65b0b 100644
--- a/nixos/modules/services/misc/nix-gc.nix
+++ b/nixos/modules/services/misc/nix-gc.nix
@@ -53,7 +53,7 @@ in
     systemd.services.nix-gc =
       { description = "Nix Garbage Collector";
         script = "exec ${config.nix.package.out}/bin/nix-collect-garbage ${cfg.options}";
-        startAt = optionalString cfg.automatic cfg.dates;
+        startAt = optional cfg.automatic cfg.dates;
       };
 
   };