summary refs log tree commit diff
path: root/nixos/modules/services/misc/nix-daemon.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2018-03-01 14:38:53 -0500
committerShea Levy <shea@shealevy.com>2018-03-01 14:38:53 -0500
commitfec543436d4d35dacde01a9e8b69a2781841f901 (patch)
treeb44b65ddbc7482e767d562f3f27c523c9ffbfcc0 /nixos/modules/services/misc/nix-daemon.nix
parente70f61f5a19b00337082ab28a5013e0b440bda92 (diff)
downloadnixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.gz
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.bz2
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.lz
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.xz
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.zst
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.zip
nixos: Move uses of stdenv.shell to runtimeShell.
Diffstat (limited to 'nixos/modules/services/misc/nix-daemon.nix')
-rw-r--r--nixos/modules/services/misc/nix-daemon.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/misc/nix-daemon.nix b/nixos/modules/services/misc/nix-daemon.nix
index a169b0f2c784..c076f90e5403 100644
--- a/nixos/modules/services/misc/nix-daemon.nix
+++ b/nixos/modules/services/misc/nix-daemon.nix
@@ -30,7 +30,7 @@ let
       # /bin/sh in the sandbox as a bind-mount to bash. This means we
       # also need to include the entire closure of bash. Nix >= 2.0
       # provides a /bin/sh by default.
-      sh = pkgs.stdenv.shell;
+      sh = pkgs.runtimeShell;
       binshDeps = pkgs.writeReferencesToFile sh;
     in
       pkgs.runCommand "nix.conf" { extraOptions = cfg.extraOptions; inherit binshDeps; } ''