summary refs log tree commit diff
path: root/nixos/modules/services/misc/nix-daemon.nix
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2017-03-05 14:04:47 +0100
committerBjørn Forsman <bjorn.forsman@gmail.com>2017-03-05 14:07:23 +0100
commit316e7d67646d2d12382871ca439db99ba168740c (patch)
tree71dc0d48ab8703961311d2d4c6f1c72b16f0167c /nixos/modules/services/misc/nix-daemon.nix
parent4da420709d1408addd0cfd1406c18e7ec3d1d941 (diff)
downloadnixlib-316e7d67646d2d12382871ca439db99ba168740c.tar
nixlib-316e7d67646d2d12382871ca439db99ba168740c.tar.gz
nixlib-316e7d67646d2d12382871ca439db99ba168740c.tar.bz2
nixlib-316e7d67646d2d12382871ca439db99ba168740c.tar.lz
nixlib-316e7d67646d2d12382871ca439db99ba168740c.tar.xz
nixlib-316e7d67646d2d12382871ca439db99ba168740c.tar.zst
nixlib-316e7d67646d2d12382871ca439db99ba168740c.zip
nixos/nix-daemon: doc: use literalExample
Makes the example more readable by not squashed everything onto one
single line.
Diffstat (limited to 'nixos/modules/services/misc/nix-daemon.nix')
-rw-r--r--nixos/modules/services/misc/nix-daemon.nix33
1 files changed, 17 insertions, 16 deletions
diff --git a/nixos/modules/services/misc/nix-daemon.nix b/nixos/modules/services/misc/nix-daemon.nix
index 3027dd1c3d0e..5088c4e60691 100644
--- a/nixos/modules/services/misc/nix-daemon.nix
+++ b/nixos/modules/services/misc/nix-daemon.nix
@@ -164,22 +164,23 @@ in
       buildMachines = mkOption {
         type = types.listOf types.attrs;
         default = [];
-        example = [
-          { hostName = "voila.labs.cs.uu.nl";
-            sshUser = "nix";
-            sshKey = "/root/.ssh/id_buildfarm";
-            system = "powerpc-darwin";
-            maxJobs = 1;
-          }
-          { hostName = "linux64.example.org";
-            sshUser = "buildfarm";
-            sshKey = "/root/.ssh/id_buildfarm";
-            system = "x86_64-linux";
-            maxJobs = 2;
-            supportedFeatures = [ "kvm" ];
-            mandatoryFeatures = [ "perf" ];
-          }
-        ];
+        example = literalExample ''
+          [ { hostName = "voila.labs.cs.uu.nl";
+              sshUser = "nix";
+              sshKey = "/root/.ssh/id_buildfarm";
+              system = "powerpc-darwin";
+              maxJobs = 1;
+            }
+            { hostName = "linux64.example.org";
+              sshUser = "buildfarm";
+              sshKey = "/root/.ssh/id_buildfarm";
+              system = "x86_64-linux";
+              maxJobs = 2;
+              supportedFeatures = [ "kvm" ];
+              mandatoryFeatures = [ "perf" ];
+            }
+          ]
+        '';
         description = ''
           This option lists the machines to be used if distributed
           builds are enabled (see