summary refs log tree commit diff
path: root/nixos/modules/services/misc/ihaskell.nix
diff options
context:
space:
mode:
authorThomas Strobel <ts468@cam.ac.uk>2016-02-20 01:47:01 +0100
committerThomas Strobel <ts468@cam.ac.uk>2016-02-29 01:09:00 +0100
commitcad8957eabcbf73062226d28366fd446c15c8737 (patch)
tree0299e96391c14f612e7bd1cf3b2274198425fd61 /nixos/modules/services/misc/ihaskell.nix
parentc483224c82c8e94324c03576e64c5dfbf16bd2f8 (diff)
downloadnixlib-cad8957eabcbf73062226d28366fd446c15c8737.tar
nixlib-cad8957eabcbf73062226d28366fd446c15c8737.tar.gz
nixlib-cad8957eabcbf73062226d28366fd446c15c8737.tar.bz2
nixlib-cad8957eabcbf73062226d28366fd446c15c8737.tar.lz
nixlib-cad8957eabcbf73062226d28366fd446c15c8737.tar.xz
nixlib-cad8957eabcbf73062226d28366fd446c15c8737.tar.zst
nixlib-cad8957eabcbf73062226d28366fd446c15c8737.zip
Add the tool "nixos-typecheck" that can check an option declaration to:
 - Enforce that an option declaration has a "defaultText" if and only if the
   type of the option derives from "package", "packageSet" or "nixpkgsConfig"
   and if a "default" attribute is defined.

 - Enforce that the value of the "example" attribute is wrapped with "literalExample"
   if the type of the option derives from "package", "packageSet" or "nixpkgsConfig".

 - Warn if a "defaultText" is defined in an option declaration if the type of
   the option does not derive from "package", "packageSet" or "nixpkgsConfig".

 - Warn if no "type" is defined in an option declaration.
Diffstat (limited to 'nixos/modules/services/misc/ihaskell.nix')
-rw-r--r--nixos/modules/services/misc/ihaskell.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/nixos/modules/services/misc/ihaskell.nix b/nixos/modules/services/misc/ihaskell.nix
index d0e9b839e754..c177d68c8fe0 100644
--- a/nixos/modules/services/misc/ihaskell.nix
+++ b/nixos/modules/services/misc/ihaskell.nix
@@ -15,12 +15,14 @@ in
   options = {
     services.ihaskell = {
       enable = mkOption {
+        type = lib.types.bool;
         default = false;
         example = true;
         description = "Autostart an IHaskell notebook service.";
       };
 
       haskellPackages = mkOption {
+        type = lib.types.packageSet;
         default = pkgs.haskellPackages;
         defaultText = "pkgs.haskellPackages";
         example = literalExample "pkgs.haskell.packages.ghc784";
@@ -33,7 +35,9 @@ in
       };
 
       extraPackages = mkOption {
+        type = types.functionTo (types.listOf types.package);
         default = self: [];
+        defaultText = "self: []";
         example = literalExample ''
           haskellPackages: [
             haskellPackages.wreq