summary refs log tree commit diff
path: root/nixos/modules/services/misc/gitlab.nix
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2016-11-21 16:26:03 +0100
committerJoachim Fasting <joachifm@fastmail.fm>2016-11-21 16:35:15 +0100
commitf9f354faadb32ae2f0ac11eab0d824cc40f1d56c (patch)
tree42f71984de12c2663740466ca6fe89550837b71d /nixos/modules/services/misc/gitlab.nix
parentd69dce080daf2c7004a79950e73dba6545b9097e (diff)
downloadnixlib-f9f354faadb32ae2f0ac11eab0d824cc40f1d56c.tar
nixlib-f9f354faadb32ae2f0ac11eab0d824cc40f1d56c.tar.gz
nixlib-f9f354faadb32ae2f0ac11eab0d824cc40f1d56c.tar.bz2
nixlib-f9f354faadb32ae2f0ac11eab0d824cc40f1d56c.tar.lz
nixlib-f9f354faadb32ae2f0ac11eab0d824cc40f1d56c.tar.xz
nixlib-f9f354faadb32ae2f0ac11eab0d824cc40f1d56c.tar.zst
nixlib-f9f354faadb32ae2f0ac11eab0d824cc40f1d56c.zip
nixos/modules: use defaultText where applicable
Primarily to fix rendering of these default values in the manual but
it's also nice to avoid having to eval these things just to build the
manual.
Diffstat (limited to 'nixos/modules/services/misc/gitlab.nix')
-rw-r--r--nixos/modules/services/misc/gitlab.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nixos/modules/services/misc/gitlab.nix b/nixos/modules/services/misc/gitlab.nix
index 3e4584c7a512..cb8fa901bbd2 100644
--- a/nixos/modules/services/misc/gitlab.nix
+++ b/nixos/modules/services/misc/gitlab.nix
@@ -164,18 +164,21 @@ in {
       packages.gitlab = mkOption {
         type = types.package;
         default = pkgs.gitlab;
+        defaultText = "pkgs.gitlab";
         description = "Reference to the gitlab package";
       };
 
       packages.gitlab-shell = mkOption {
         type = types.package;
         default = pkgs.gitlab-shell;
+        defaultText = "pkgs.gitlab-shell";
         description = "Reference to the gitlab-shell package";
       };
 
       packages.gitlab-workhorse = mkOption {
         type = types.package;
         default = pkgs.gitlab-workhorse;
+        defaultText = "pkgs.gitlab-workhorse";
         description = "Reference to the gitlab-workhorse package";
       };