summary refs log tree commit diff
path: root/nixos/modules/services/misc/gitlab.nix
diff options
context:
space:
mode:
authorMárton Boros <martonboros@gmail.com>2017-10-22 14:09:38 +0200
committerRobin Gloster <mail@glob.in>2017-10-22 15:23:25 +0200
commita89b28f8b7e3281074ca29beca332a5aea598bc6 (patch)
treeaa6bd01da4b1cec99a2c25387e4f2bc687512cfe /nixos/modules/services/misc/gitlab.nix
parent0f0f0cbc6fb11f8537c3fe293a8451174106274c (diff)
downloadnixlib-a89b28f8b7e3281074ca29beca332a5aea598bc6.tar
nixlib-a89b28f8b7e3281074ca29beca332a5aea598bc6.tar.gz
nixlib-a89b28f8b7e3281074ca29beca332a5aea598bc6.tar.bz2
nixlib-a89b28f8b7e3281074ca29beca332a5aea598bc6.tar.lz
nixlib-a89b28f8b7e3281074ca29beca332a5aea598bc6.tar.xz
nixlib-a89b28f8b7e3281074ca29beca332a5aea598bc6.tar.zst
nixlib-a89b28f8b7e3281074ca29beca332a5aea598bc6.zip
nixos/gitlab: fix startup script
The preStart script used a hardcoded "git" user instead of the cfg value.
Diffstat (limited to 'nixos/modules/services/misc/gitlab.nix')
-rw-r--r--nixos/modules/services/misc/gitlab.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/misc/gitlab.nix b/nixos/modules/services/misc/gitlab.nix
index 1399a36ffeed..740cbc141b53 100644
--- a/nixos/modules/services/misc/gitlab.nix
+++ b/nixos/modules/services/misc/gitlab.nix
@@ -646,7 +646,7 @@ in {
         chmod -R ug-s ${cfg.statePath}/repositories
         find ${cfg.statePath}/repositories -type d -print0 | xargs -0 chmod g+s
         chmod 770 ${cfg.statePath}/uploads
-        chown -R git ${cfg.statePath}/uploads
+        chown -R ${cfg.user} ${cfg.statePath}/uploads
         find ${cfg.statePath}/uploads -type f -exec chmod 0644 {} \;
         find ${cfg.statePath}/uploads -type d -not -path ${cfg.statePath}/uploads -exec chmod 0770 {} \;
       '';