summary refs log tree commit diff
path: root/nixos/modules/services/misc/gitlab.nix
diff options
context:
space:
mode:
authorMárton Boros <martonboros@gmail.com>2017-10-23 23:27:24 +0200
committerRobin Gloster <mail@glob.in>2017-10-30 12:49:27 +0100
commit29e80bde404b5ed126fdc2f32e794556506a9cc9 (patch)
treeb12f79fd89ffff7cfde7e027dfef42635c7a58ac /nixos/modules/services/misc/gitlab.nix
parentb8a7c455f6e5eef0fe6d9d65701816cbf3662f57 (diff)
downloadnixlib-29e80bde404b5ed126fdc2f32e794556506a9cc9.tar
nixlib-29e80bde404b5ed126fdc2f32e794556506a9cc9.tar.gz
nixlib-29e80bde404b5ed126fdc2f32e794556506a9cc9.tar.bz2
nixlib-29e80bde404b5ed126fdc2f32e794556506a9cc9.tar.lz
nixlib-29e80bde404b5ed126fdc2f32e794556506a9cc9.tar.xz
nixlib-29e80bde404b5ed126fdc2f32e794556506a9cc9.tar.zst
nixlib-29e80bde404b5ed126fdc2f32e794556506a9cc9.zip
nixos/gitlab: fix hard-coded database name
Diffstat (limited to 'nixos/modules/services/misc/gitlab.nix')
-rw-r--r--nixos/modules/services/misc/gitlab.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/misc/gitlab.nix b/nixos/modules/services/misc/gitlab.nix
index 740cbc141b53..0dde9ff3c5a5 100644
--- a/nixos/modules/services/misc/gitlab.nix
+++ b/nixos/modules/services/misc/gitlab.nix
@@ -619,7 +619,7 @@ in {
         fi
 
         # enable required pg_trgm extension for gitlab
-        ${pkgs.sudo}/bin/sudo -u ${pgSuperUser} psql gitlab -c "CREATE EXTENSION IF NOT EXISTS pg_trgm"
+        ${pkgs.sudo}/bin/sudo -u ${pgSuperUser} psql ${cfg.databaseName} -c "CREATE EXTENSION IF NOT EXISTS pg_trgm"
         # Always do the db migrations just to be sure the database is up-to-date
         ${gitlab-rake}/bin/gitlab-rake db:migrate RAILS_ENV=production