summary refs log tree commit diff
path: root/nixos/modules/services/mail/rmilter.nix
diff options
context:
space:
mode:
authorAlexander V. Nikolaev <avn@avnik.info>2016-03-25 16:12:16 +0200
committerAlexander V. Nikolaev <avn@avnik.info>2016-04-28 14:21:18 +0300
commit5c260399e136631e026c17b9c08315660f9eaefc (patch)
tree213206f5f1b598329e5ee226316af328217b3a23 /nixos/modules/services/mail/rmilter.nix
parent5d26e806451d3f51833e13d3cbbc173370cdcbfa (diff)
downloadnixlib-5c260399e136631e026c17b9c08315660f9eaefc.tar
nixlib-5c260399e136631e026c17b9c08315660f9eaefc.tar.gz
nixlib-5c260399e136631e026c17b9c08315660f9eaefc.tar.bz2
nixlib-5c260399e136631e026c17b9c08315660f9eaefc.tar.lz
nixlib-5c260399e136631e026c17b9c08315660f9eaefc.tar.xz
nixlib-5c260399e136631e026c17b9c08315660f9eaefc.tar.zst
nixlib-5c260399e136631e026c17b9c08315660f9eaefc.zip
rmilter: correct paths to sockets
Diffstat (limited to 'nixos/modules/services/mail/rmilter.nix')
-rw-r--r--nixos/modules/services/mail/rmilter.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/nixos/modules/services/mail/rmilter.nix b/nixos/modules/services/mail/rmilter.nix
index f748e7a172ea..d1f7cd2e173e 100644
--- a/nixos/modules/services/mail/rmilter.nix
+++ b/nixos/modules/services/mail/rmilter.nix
@@ -75,12 +75,12 @@ in
 
       bindUnixSockets =  mkOption {
         type = types.listOf types.str;
-        default = ["/run/rmilter/rmilter.sock"];
+        default = ["/run/rmilter.sock"];
         description = ''
           Unix domain sockets to listen for MTA requests.
         '';
         example = ''
-            [ "/run/rmilter/rmilter.sock"] 
+            [ "/run/rmilter.sock"]
         '';
       };
 
@@ -114,7 +114,7 @@ in
 
         servers = mkOption {
           type = types.listOf types.str;
-          default = ["r:/run/rspamd/rspamd.sock"];
+          default = ["r:/run/rspamd.sock"];
           description = ''
             Spamd socket definitions.
             Is server name is prefixed with r: it is rspamd server.
@@ -214,13 +214,13 @@ milter_default_action = accept
       socketConfig = {
           ListenStream = cfg.bindUnixSockets ++ cfg.bindInetSockets;
           SocketUser = cfg.user;
-          SocketGroup = config.ids.gids.adm;
+          SocketGroup = cfg.group;
           SocketMode = "0660";
       };
     };
 
     services.postfix.extraConfig = optionalString cfg.postfix.enable cfg.postfix.configFragment;
-
+    users.users.postfix.extraGroups = [ cfg.group ];
   };
 
 }