summary refs log tree commit diff
path: root/nixos/modules/services/mail/dovecot.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-01-06 23:09:06 +0300
committerNikolay Amiantov <ab@fmap.me>2016-01-21 12:53:24 +0300
commitd1a9c55d910af49a93023f9e7de44bdf4a5cc03c (patch)
tree3e38013680a8af621eae4b591aebee6b269a77f5 /nixos/modules/services/mail/dovecot.nix
parentec15cea84f185846702ed366ac82e2f068eb74ea (diff)
downloadnixlib-d1a9c55d910af49a93023f9e7de44bdf4a5cc03c.tar
nixlib-d1a9c55d910af49a93023f9e7de44bdf4a5cc03c.tar.gz
nixlib-d1a9c55d910af49a93023f9e7de44bdf4a5cc03c.tar.bz2
nixlib-d1a9c55d910af49a93023f9e7de44bdf4a5cc03c.tar.lz
nixlib-d1a9c55d910af49a93023f9e7de44bdf4a5cc03c.tar.xz
nixlib-d1a9c55d910af49a93023f9e7de44bdf4a5cc03c.tar.zst
nixlib-d1a9c55d910af49a93023f9e7de44bdf4a5cc03c.zip
nixos/dovecot: add reload command
Diffstat (limited to 'nixos/modules/services/mail/dovecot.nix')
-rw-r--r--nixos/modules/services/mail/dovecot.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/services/mail/dovecot.nix b/nixos/modules/services/mail/dovecot.nix
index 36bdcaca47a3..e8eaeafff3e9 100644
--- a/nixos/modules/services/mail/dovecot.nix
+++ b/nixos/modules/services/mail/dovecot.nix
@@ -162,7 +162,7 @@ in
     enablePAM = mkOption {
       type = types.bool;
       default = true;
-      description = "Wether to create a own Dovecot PAM service and configure PAM user logins.";
+      description = "Whether to create a own Dovecot PAM service and configure PAM user logins.";
     };
 
     showPAMFailure = mkOption {
@@ -211,6 +211,7 @@ in
 
       serviceConfig = {
         ExecStart = "${dovecotPkg}/sbin/dovecot -F -c ${cfg.configFile}";
+        ExecReload = "${dovecotPkg}/sbin/doveadm reload -c ${cfg.configFile}";
         Restart = "on-failure";
         RestartSec = "1s";
         StartLimitInterval = "1min";