summary refs log tree commit diff
path: root/nixos/modules/services/logging/logstash.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-12-20 18:27:29 +0100
committermakefu <github@syntax-fehler.de>2017-01-13 10:19:32 +0100
commite9c6cf02e6886bfc91f3bb866184e95054199ff1 (patch)
treeded9e07e981e0e4fc5c6cdb7025056932ae6784e /nixos/modules/services/logging/logstash.nix
parent10303e9e47525389334222a441010edebe972513 (diff)
downloadnixlib-e9c6cf02e6886bfc91f3bb866184e95054199ff1.tar
nixlib-e9c6cf02e6886bfc91f3bb866184e95054199ff1.tar.gz
nixlib-e9c6cf02e6886bfc91f3bb866184e95054199ff1.tar.bz2
nixlib-e9c6cf02e6886bfc91f3bb866184e95054199ff1.tar.lz
nixlib-e9c6cf02e6886bfc91f3bb866184e95054199ff1.tar.xz
nixlib-e9c6cf02e6886bfc91f3bb866184e95054199ff1.tar.zst
nixlib-e9c6cf02e6886bfc91f3bb866184e95054199ff1.zip
services.logstash: rename address to listenAddress
Diffstat (limited to 'nixos/modules/services/logging/logstash.nix')
-rw-r--r--nixos/modules/services/logging/logstash.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/logging/logstash.nix b/nixos/modules/services/logging/logstash.nix
index d9b370392551..c9477b9e3ab0 100644
--- a/nixos/modules/services/logging/logstash.nix
+++ b/nixos/modules/services/logging/logstash.nix
@@ -63,7 +63,7 @@ in
         description = "Enable the logstash web interface.";
       };
 
-      address = mkOption {
+      listenAddress = mkOption {
         type = types.str;
         default = "0.0.0.0";
         description = "Address on which to start webserver.";
@@ -147,7 +147,7 @@ in
               ${cfg.outputConfig}
             }
           ''} " +
-          ops cfg.enableWeb "-- web -a ${cfg.address} -p ${cfg.port}";
+          ops cfg.enableWeb "-- web -a ${cfg.listenAddress} -p ${cfg.port}";
       };
     };
   };