summary refs log tree commit diff
path: root/nixos/modules/services/hardware/udev.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-28 16:14:15 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-28 22:45:56 +0100
commitd5047faedef254d01a21618224698c190bb67e5b (patch)
tree42a43de15611b5e35b2888f02fb940365edb1402 /nixos/modules/services/hardware/udev.nix
parentf4a418761b481b15900c78b8086e7be58b0afe4e (diff)
downloadnixlib-d5047faedef254d01a21618224698c190bb67e5b.tar
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.gz
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.bz2
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.lz
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.xz
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.zst
nixlib-d5047faedef254d01a21618224698c190bb67e5b.zip
Remove uses of the "merge" option attribute
It's redundant because you can (and should) specify an option type, or
an apply function.
Diffstat (limited to 'nixos/modules/services/hardware/udev.nix')
-rw-r--r--nixos/modules/services/hardware/udev.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/services/hardware/udev.nix b/nixos/modules/services/hardware/udev.nix
index 37dba8ce71dc..75f01fbc5a95 100644
--- a/nixos/modules/services/hardware/udev.nix
+++ b/nixos/modules/services/hardware/udev.nix
@@ -126,8 +126,8 @@ in
     services.udev = {
 
       packages = mkOption {
+        type = types.listOf types.path;
         default = [];
-        merge = mergeListOption;
         description = ''
           List of packages containing <command>udev</command> rules.
           All files found in
@@ -138,8 +138,8 @@ in
       };
 
       path = mkOption {
+        type = types.listOf types.path;
         default = [];
-        merge = mergeListOption;
         description = ''
           Packages added to the <envar>PATH</envar> environment variable when
           executing programs from Udev rules.
@@ -162,9 +162,9 @@ in
     };
 
     hardware.firmware = mkOption {
+      type = types.listOf types.path;
       default = [];
       example = [ "/root/my-firmware" ];
-      merge = mergeListOption;
       description = ''
         List of directories containing firmware files.  Such files
         will be loaded automatically if the kernel asks for them