summary refs log tree commit diff
path: root/nixos/modules/services/hardware/tcsd.nix
diff options
context:
space:
mode:
authorAlexander Kjeldaas <ak@formalprivacy.com>2014-04-22 13:39:28 +0200
committerAlexander Kjeldaas <ak@formalprivacy.com>2014-04-22 14:05:09 +0200
commit4cca346d21aa164729164f6568fa60225f0fb4ea (patch)
tree7e1dc6fdb333e0efa38787d178e4e61f748ffe92 /nixos/modules/services/hardware/tcsd.nix
parent5065802b3aa32d9ebe02756bbe4e51032c53ecef (diff)
downloadnixlib-4cca346d21aa164729164f6568fa60225f0fb4ea.tar
nixlib-4cca346d21aa164729164f6568fa60225f0fb4ea.tar.gz
nixlib-4cca346d21aa164729164f6568fa60225f0fb4ea.tar.bz2
nixlib-4cca346d21aa164729164f6568fa60225f0fb4ea.tar.lz
nixlib-4cca346d21aa164729164f6568fa60225f0fb4ea.tar.xz
nixlib-4cca346d21aa164729164f6568fa60225f0fb4ea.tar.zst
nixlib-4cca346d21aa164729164f6568fa60225f0fb4ea.zip
Add types to tcsd config options.
Diffstat (limited to 'nixos/modules/services/hardware/tcsd.nix')
-rw-r--r--nixos/modules/services/hardware/tcsd.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/nixos/modules/services/hardware/tcsd.nix b/nixos/modules/services/hardware/tcsd.nix
index 7499cd349f7b..26b2c884b8f1 100644
--- a/nixos/modules/services/hardware/tcsd.nix
+++ b/nixos/modules/services/hardware/tcsd.nix
@@ -38,6 +38,7 @@ in
 
       enable = mkOption {
         default = false;
+        type = types.bool;
         description = ''
           Whether to enable tcsd, a Trusted Computing management service
           that provides TCG Software Stack (TSS).  The tcsd daemon is
@@ -48,16 +49,19 @@ in
 
       user = mkOption {
         default = "tss";
+        type = types.string;
         description = "User account under which tcsd runs.";
       };
 
       group = mkOption {
         default = "tss";
+        type = types.string;
         description = "Group account under which tcsd runs.";
       };
 
       stateDir = mkOption {
 	default = "/var/lib/tpm";
+        type = types.path;
 	description = ''
           The location of the system persistent storage file.
           The system persistent storage file holds keys and data across
@@ -67,6 +71,7 @@ in
 
       platformCred = mkOption {
         default = "${cfg.stateDir}/platform.cert";
+        type = types.path;
         description = ''
 	  Path to the platform credential for your TPM. Your TPM
           manufacturer may have provided you with a set of credentials
@@ -79,6 +84,7 @@ in
 
       conformanceCred = mkOption {
         default = "${cfg.stateDir}/conformance.cert";
+        type = types.path;
         description = ''
           Path to the conformance credential for your TPM.
           See also the platformCred option'';
@@ -86,6 +92,7 @@ in
 
       endorsementCred = mkOption {
         default = "${cfg.stateDir}/endorsement.cert";
+        type = types.path;
         description = ''
           Path to the endorsement credential for your TPM.
           See also the platformCred option'';