summary refs log tree commit diff
path: root/nixos/modules/services/hardware/freefall.nix
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-01-08 23:38:10 +0100
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-01-28 15:59:21 +0100
commitff5eae075a6a42994b8ae406afdb4cb64146f4b0 (patch)
treed3bb5eed8b6ce8318da9e9ad32cf3948f151386e /nixos/modules/services/hardware/freefall.nix
parent94a600772edf2568985837953958a82ab3cc599a (diff)
downloadnixlib-ff5eae075a6a42994b8ae406afdb4cb64146f4b0.tar
nixlib-ff5eae075a6a42994b8ae406afdb4cb64146f4b0.tar.gz
nixlib-ff5eae075a6a42994b8ae406afdb4cb64146f4b0.tar.bz2
nixlib-ff5eae075a6a42994b8ae406afdb4cb64146f4b0.tar.lz
nixlib-ff5eae075a6a42994b8ae406afdb4cb64146f4b0.tar.xz
nixlib-ff5eae075a6a42994b8ae406afdb4cb64146f4b0.tar.zst
nixlib-ff5eae075a6a42994b8ae406afdb4cb64146f4b0.zip
Add freefall NixOS service module
Diffstat (limited to 'nixos/modules/services/hardware/freefall.nix')
-rw-r--r--nixos/modules/services/hardware/freefall.nix62
1 files changed, 62 insertions, 0 deletions
diff --git a/nixos/modules/services/hardware/freefall.nix b/nixos/modules/services/hardware/freefall.nix
new file mode 100644
index 000000000000..6e6960bac491
--- /dev/null
+++ b/nixos/modules/services/hardware/freefall.nix
@@ -0,0 +1,62 @@
+{ config, lib, pkgs, utils, ... }:
+
+with lib;
+
+{
+
+  ###### interface
+
+  options = with types; {
+
+    services.freefall = {
+
+      enable = mkOption {
+        default = false;
+        description = ''
+          Whether to protect HP/Dell laptop hard drives (not SSDs) in free fall.
+        '';
+        type = bool;
+      };
+
+      devices = mkOption {
+        default = [ "/dev/sda" ];
+        description = ''
+          Device paths to all internal spinning hard drives.
+        '';
+        type = listOf string;
+      };
+
+    };
+
+  };
+
+  ###### implementation
+
+  config = let
+
+    cfg = config.services.freefall;
+
+    mkService = dev:
+      assert dev != "";
+      let dev' = utils.escapeSystemdPath dev; in
+      nameValuePair "freefall-${dev'}"
+        { description = "Free-fall protection for ${dev}";
+        after = [ "${dev'}.device" ];
+        wantedBy = [ "${dev'}.device" ];
+        path = [ pkgs.freefall ];
+        serviceConfig = {
+          ExecStart = "${pkgs.freefall}/bin/freefall ${dev}";
+          Restart = "on-failure";
+          Type = "forking";
+        };
+      };
+
+  in mkIf cfg.enable {
+
+    environment.systemPackages = [ pkgs.freefall ];
+
+    systemd.services = listToAttrs (map mkService cfg.devices);
+
+  };
+
+}