summary refs log tree commit diff
path: root/nixos/modules/services/hardware/brltty.nix
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2016-12-18 11:47:12 +0100
committerJoachim Fasting <joachifm@fastmail.fm>2016-12-18 12:42:14 +0100
commitc27eeeafd95b6e6f7e059f2a69ce2168c439e068 (patch)
treee8e6959555d34a2fbd14670bbe346c27639e6064 /nixos/modules/services/hardware/brltty.nix
parentfeb6dbc9162719123178c2c0455a5b2b792f15d6 (diff)
downloadnixlib-c27eeeafd95b6e6f7e059f2a69ce2168c439e068.tar
nixlib-c27eeeafd95b6e6f7e059f2a69ce2168c439e068.tar.gz
nixlib-c27eeeafd95b6e6f7e059f2a69ce2168c439e068.tar.bz2
nixlib-c27eeeafd95b6e6f7e059f2a69ce2168c439e068.tar.lz
nixlib-c27eeeafd95b6e6f7e059f2a69ce2168c439e068.tar.xz
nixlib-c27eeeafd95b6e6f7e059f2a69ce2168c439e068.tar.zst
nixlib-c27eeeafd95b6e6f7e059f2a69ce2168c439e068.zip
brltty service: wait for devices to settle
Otherwise it starts way too early, only to fail and having to restart
until devices are available.  It is less wasteful to simply wait until
there's a reasonable chance of success.  This is consistent with
upstream.
Diffstat (limited to 'nixos/modules/services/hardware/brltty.nix')
-rw-r--r--nixos/modules/services/hardware/brltty.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/services/hardware/brltty.nix b/nixos/modules/services/hardware/brltty.nix
index b416ba332222..1266e8f81e5b 100644
--- a/nixos/modules/services/hardware/brltty.nix
+++ b/nixos/modules/services/hardware/brltty.nix
@@ -39,6 +39,8 @@ in {
         ProtectSystem = "full";
         SystemCallArchitectures = "native";
       };
+      wants = [ "systemd-udev-settle.service" ];
+      after = [ "local-fs.target" "systemd-udev-settle.service" ];
       before = [ "sysinit.target" ];
       wantedBy = [ "sysinit.target" ];
     };