summary refs log tree commit diff
path: root/nixos/modules/services/desktops/geoclue2.nix
diff options
context:
space:
mode:
authorLuca Bruno <lucabru@src.gnome.org>2014-04-24 23:32:32 +0200
committerLuca Bruno <lucabru@src.gnome.org>2014-05-02 16:04:57 +0200
commitfbfccea0e8592699bf4c32ea4c07513fcca43b11 (patch)
treed064a54cbc63a23bbbedaa09f0fa5753b6349d79 /nixos/modules/services/desktops/geoclue2.nix
parent85175de878d241a627f318d69d085999c45b5550 (diff)
downloadnixlib-fbfccea0e8592699bf4c32ea4c07513fcca43b11.tar
nixlib-fbfccea0e8592699bf4c32ea4c07513fcca43b11.tar.gz
nixlib-fbfccea0e8592699bf4c32ea4c07513fcca43b11.tar.bz2
nixlib-fbfccea0e8592699bf4c32ea4c07513fcca43b11.tar.lz
nixlib-fbfccea0e8592699bf4c32ea4c07513fcca43b11.tar.xz
nixlib-fbfccea0e8592699bf4c32ea4c07513fcca43b11.tar.zst
nixlib-fbfccea0e8592699bf4c32ea4c07513fcca43b11.zip
geoclue2: add dbus service
Diffstat (limited to 'nixos/modules/services/desktops/geoclue2.nix')
-rw-r--r--nixos/modules/services/desktops/geoclue2.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/nixos/modules/services/desktops/geoclue2.nix b/nixos/modules/services/desktops/geoclue2.nix
new file mode 100644
index 000000000000..6bdd5edff1f5
--- /dev/null
+++ b/nixos/modules/services/desktops/geoclue2.nix
@@ -0,0 +1,39 @@
+# GeoClue 2 daemon.
+
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+  ###### interface
+
+  options = {
+
+    services.geoclue2 = {
+
+      enable = mkOption {
+        type = types.bool;
+        default = false;
+        description = ''
+          Whether to enable GeoClue 2 daemon, a DBus service
+          that provides location informationfor accessing.
+        '';
+      };
+
+    };
+
+  };
+
+
+  ###### implementation
+
+  config = mkIf config.services.geoclue2.enable {
+
+    environment.systemPackages = [ pkgs.geoclue2 ];
+
+    services.dbus.packages = [ pkgs.geoclue2 ];
+
+  };
+
+}