summary refs log tree commit diff
path: root/nixos/modules/services/cluster/kubernetes.nix
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2016-11-11 23:11:54 +0100
committerPascal Bach <pascal.bach@nextrem.ch>2016-11-11 23:11:54 +0100
commitc1dca9e40b7f357460f69e08e568b242c6e1bdfa (patch)
treeb1644624321575af4c36d3b61979049a2d3601d6 /nixos/modules/services/cluster/kubernetes.nix
parent0838c10e22c30dda7cda5fe43e891c69dd0dbe63 (diff)
downloadnixlib-c1dca9e40b7f357460f69e08e568b242c6e1bdfa.tar
nixlib-c1dca9e40b7f357460f69e08e568b242c6e1bdfa.tar.gz
nixlib-c1dca9e40b7f357460f69e08e568b242c6e1bdfa.tar.bz2
nixlib-c1dca9e40b7f357460f69e08e568b242c6e1bdfa.tar.lz
nixlib-c1dca9e40b7f357460f69e08e568b242c6e1bdfa.tar.xz
nixlib-c1dca9e40b7f357460f69e08e568b242c6e1bdfa.tar.zst
nixlib-c1dca9e40b7f357460f69e08e568b242c6e1bdfa.zip
etcd: make all service using etc go to 127.0.0.1:2379 by default
The old etcd port 4001 is no longer enabled by default in etcd 3.
The new port is 2379 and is officially assigned by IANA.

There were still some services left that expect etcd on port 4001 by default.
This changes the default to 2379 everywhere.

It should not cause problems for users as the etcd by nix does listen on the new port only by default anyway.
Diffstat (limited to 'nixos/modules/services/cluster/kubernetes.nix')
-rw-r--r--nixos/modules/services/cluster/kubernetes.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/services/cluster/kubernetes.nix b/nixos/modules/services/cluster/kubernetes.nix
index 4bdd7f95f774..19303e97a706 100644
--- a/nixos/modules/services/cluster/kubernetes.nix
+++ b/nixos/modules/services/cluster/kubernetes.nix
@@ -23,7 +23,7 @@ in {
 
     etcdServers = mkOption {
       description = "Kubernetes list of etcd servers to watch.";
-      default = [ "127.0.0.1:4001" ];
+      default = [ "127.0.0.1:2379" ];
       type = types.listOf types.str;
     };