summary refs log tree commit diff
path: root/nixos/modules/security/polkit.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-01-28 11:24:18 +0100
committerVladimír Čunát <vcunat@gmail.com>2016-01-28 11:24:18 +0100
commitab8a691d059b364c435a1871ae2ef70a578685d8 (patch)
treea9158496e379970c0cb25b4068488c46fccc3f16 /nixos/modules/security/polkit.nix
parenta33fcc873110a6ded62f3286d9850ac5a445df89 (diff)
downloadnixlib-ab8a691d059b364c435a1871ae2ef70a578685d8.tar
nixlib-ab8a691d059b364c435a1871ae2ef70a578685d8.tar.gz
nixlib-ab8a691d059b364c435a1871ae2ef70a578685d8.tar.bz2
nixlib-ab8a691d059b364c435a1871ae2ef70a578685d8.tar.lz
nixlib-ab8a691d059b364c435a1871ae2ef70a578685d8.tar.xz
nixlib-ab8a691d059b364c435a1871ae2ef70a578685d8.tar.zst
nixlib-ab8a691d059b364c435a1871ae2ef70a578685d8.zip
nixos systemPackages: rework default outputs
- Now `pkg.outputUnspecified = true` but this attribute is missing in
  every output, so we can recognize whether the user chose or not.
  If (s)he didn't choose, we put `pkg.bin or pkg.out or pkg` into
  `systemPackages`.
- `outputsToLink` is replaced by `extraOutputsToLink`.
  We add extra outputs *regardless* of whether the user chose anything.
  It's mainly meant for outputs with docs and debug symbols.
- Note that as a result, some libraries will disappear from system path.
Diffstat (limited to 'nixos/modules/security/polkit.nix')
-rw-r--r--nixos/modules/security/polkit.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/security/polkit.nix b/nixos/modules/security/polkit.nix
index 70e5e8b9fa74..507f81bbf073 100644
--- a/nixos/modules/security/polkit.nix
+++ b/nixos/modules/security/polkit.nix
@@ -59,7 +59,7 @@ in
 
   config = mkIf cfg.enable {
 
-    environment.systemPackages = [ pkgs.polkit ];
+    environment.systemPackages = [ pkgs.polkit.bin pkgs.polkit.out ];
 
     systemd.packages = [ pkgs.polkit.out ];