summary refs log tree commit diff
path: root/nixos/modules/security/polkit.nix
diff options
context:
space:
mode:
authorParnell Springmeyer <parnell@awakenetworks.com>2016-09-01 19:06:21 -0500
committerParnell Springmeyer <parnell@awakenetworks.com>2016-09-01 19:21:06 -0500
commit98c058a1ee338731d72d33f320da48c95fecd0e0 (patch)
treefe83f2050163abfe9a73ad36ac1368fbe283cd39 /nixos/modules/security/polkit.nix
parent390ab0b3eff809052d5b9d9b5335413b36898481 (diff)
downloadnixlib-98c058a1ee338731d72d33f320da48c95fecd0e0.tar
nixlib-98c058a1ee338731d72d33f320da48c95fecd0e0.tar.gz
nixlib-98c058a1ee338731d72d33f320da48c95fecd0e0.tar.bz2
nixlib-98c058a1ee338731d72d33f320da48c95fecd0e0.tar.lz
nixlib-98c058a1ee338731d72d33f320da48c95fecd0e0.tar.xz
nixlib-98c058a1ee338731d72d33f320da48c95fecd0e0.tar.zst
nixlib-98c058a1ee338731d72d33f320da48c95fecd0e0.zip
Adapting everything for the merged permissions wrappers work.
Diffstat (limited to 'nixos/modules/security/polkit.nix')
-rw-r--r--nixos/modules/security/polkit.nix18
1 files changed, 8 insertions, 10 deletions
diff --git a/nixos/modules/security/polkit.nix b/nixos/modules/security/polkit.nix
index db078667acf0..098319d5ded3 100644
--- a/nixos/modules/security/polkit.nix
+++ b/nixos/modules/security/polkit.nix
@@ -87,20 +87,18 @@ in
       [
         { program = "pkexec";
           source  = "${pkgs.polkit.out}/bin/pkexec";
-          user    = "root";
+          owner   = "root";
           group   = "root";
           setuid  = true;
         }
-      ];
 
-    security.setuidOwners = [
-      { program = "polkit-agent-helper-1";
-        owner = "root";
-        group = "root";
-        setuid = true;
-        source = "${pkgs.polkit.out}/lib/polkit-1/polkit-agent-helper-1";
-      }
-    ];
+        { program = "polkit-agent-helper-1";
+          owner = "root";
+          group = "root";
+          setuid = true;
+          source = "${pkgs.polkit.out}/lib/polkit-1/polkit-agent-helper-1";
+        }
+      ];
 
     system.activationScripts.polkit =
       ''