summary refs log tree commit diff
path: root/nixos/modules/security/pam.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2016-09-16 15:36:31 +0200
committeraszlig <aszlig@redmoonstudios.org>2016-09-16 15:36:31 +0200
commite85e51d41f0f3be40490b0de9a76f20f3685659c (patch)
tree84914993eeb0f599229ce3b200bbb113bc5e6376 /nixos/modules/security/pam.nix
parent0201869418906c7cc8e2643bf876feb3ba27f4ab (diff)
downloadnixlib-e85e51d41f0f3be40490b0de9a76f20f3685659c.tar
nixlib-e85e51d41f0f3be40490b0de9a76f20f3685659c.tar.gz
nixlib-e85e51d41f0f3be40490b0de9a76f20f3685659c.tar.bz2
nixlib-e85e51d41f0f3be40490b0de9a76f20f3685659c.tar.lz
nixlib-e85e51d41f0f3be40490b0de9a76f20f3685659c.tar.xz
nixlib-e85e51d41f0f3be40490b0de9a76f20f3685659c.tar.zst
nixlib-e85e51d41f0f3be40490b0de9a76f20f3685659c.zip
nixos/pam: Fix wrong string concatenation
Regression introduced by 1010271c63f503113c0e8337977610ea783880ec.

This caused the line after using the loginuid module to be concatenated
with the next line without a newline.

In turn this has caused a lot of the NixOS VM tests to either run very
slowly (because of constantly hitting PAM errors) or simply fail.

I have tested this only with one of the failing NixOS tests.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/modules/security/pam.nix')
-rw-r--r--nixos/modules/security/pam.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/nixos/modules/security/pam.nix b/nixos/modules/security/pam.nix
index 6a4f6634c4b3..f6ca6877022e 100644
--- a/nixos/modules/security/pam.nix
+++ b/nixos/modules/security/pam.nix
@@ -301,11 +301,11 @@ let
            session required pam_env.so envfile=${config.system.build.pamEnvironment}
          '' + ''
            session required pam_unix.so
-         '' + optionalString cfg.setLoginUid
-              "session ${
-                if config.boot.isContainer then "optional" else "required"
-              } pam_loginuid.so"
-         + optionalString cfg.makeHomeDir ''
+         '' + optionalString cfg.setLoginUid ''
+            session ${
+              if config.boot.isContainer then "optional" else "required"
+            } pam_loginuid.so
+         '' + optionalString cfg.makeHomeDir ''
            session required ${pkgs.pam}/lib/security/pam_mkhomedir.so silent skel=/etc/skel umask=0022
          '' + optionalString cfg.updateWtmp ''
            session required ${pkgs.pam}/lib/security/pam_lastlog.so silent