summary refs log tree commit diff
path: root/nixos/modules/security/hidepid.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-08-31 17:16:30 +0300
committerNikolay Amiantov <ab@fmap.me>2016-08-31 17:16:41 +0300
commit4499a505ed9c71c2fccbd746052bdffdaac1a1e0 (patch)
tree0c9729faa1dd5556c3763180a8f4966639ade52d /nixos/modules/security/hidepid.nix
parenta4879c44c90f9cbd4c2ffbad9f544ce028ff2c83 (diff)
downloadnixlib-4499a505ed9c71c2fccbd746052bdffdaac1a1e0.tar
nixlib-4499a505ed9c71c2fccbd746052bdffdaac1a1e0.tar.gz
nixlib-4499a505ed9c71c2fccbd746052bdffdaac1a1e0.tar.bz2
nixlib-4499a505ed9c71c2fccbd746052bdffdaac1a1e0.tar.lz
nixlib-4499a505ed9c71c2fccbd746052bdffdaac1a1e0.tar.xz
nixlib-4499a505ed9c71c2fccbd746052bdffdaac1a1e0.tar.zst
nixlib-4499a505ed9c71c2fccbd746052bdffdaac1a1e0.zip
hidepid service: use new boot.specialFileSystems
Diffstat (limited to 'nixos/modules/security/hidepid.nix')
-rw-r--r--nixos/modules/security/hidepid.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/security/hidepid.nix b/nixos/modules/security/hidepid.nix
index 4917327d617c..8f2df380cfe8 100644
--- a/nixos/modules/security/hidepid.nix
+++ b/nixos/modules/security/hidepid.nix
@@ -20,6 +20,6 @@ with lib;
   config = mkIf config.security.hideProcessInformation {
     users.groups.proc.gid = config.ids.gids.proc;
 
-    fileSystems."/proc".options = [ "hidepid=2" "gid=${toString config.ids.gids.proc}" ];
+    boot.specialFileSystems."/proc".options = [ "hidepid=2" "gid=${toString config.ids.gids.proc}" ];
   };
 }