summary refs log tree commit diff
path: root/nixos/modules/security/chromium-suid-sandbox.nix
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-08-08 01:55:11 +0300
committerNikolay Amiantov <ab@fmap.me>2016-08-08 10:17:31 +0300
commitb2413e48aea29b24ae9994c2c8bddf7e96245cc2 (patch)
tree8bdaeba5d9f3cf95636c7a6c118f8145d63d7b0f /nixos/modules/security/chromium-suid-sandbox.nix
parent43da8b14a04d29cf89530626bcc9f24145917c8d (diff)
downloadnixlib-b2413e48aea29b24ae9994c2c8bddf7e96245cc2.tar
nixlib-b2413e48aea29b24ae9994c2c8bddf7e96245cc2.tar.gz
nixlib-b2413e48aea29b24ae9994c2c8bddf7e96245cc2.tar.bz2
nixlib-b2413e48aea29b24ae9994c2c8bddf7e96245cc2.tar.lz
nixlib-b2413e48aea29b24ae9994c2c8bddf7e96245cc2.tar.xz
nixlib-b2413e48aea29b24ae9994c2c8bddf7e96245cc2.tar.zst
nixlib-b2413e48aea29b24ae9994c2c8bddf7e96245cc2.zip
chromium-suid-sandbox module: fix description
Diffstat (limited to 'nixos/modules/security/chromium-suid-sandbox.nix')
-rw-r--r--nixos/modules/security/chromium-suid-sandbox.nix24
1 files changed, 14 insertions, 10 deletions
diff --git a/nixos/modules/security/chromium-suid-sandbox.nix b/nixos/modules/security/chromium-suid-sandbox.nix
index b517e879f04e..88fbe518c2de 100644
--- a/nixos/modules/security/chromium-suid-sandbox.nix
+++ b/nixos/modules/security/chromium-suid-sandbox.nix
@@ -7,19 +7,23 @@ let
   sandbox = pkgs.chromium.sandbox;
 in
 {
-  options.security.chromiumSuidSandbox.enable = mkEnableOption ''
-    Whether to install the Chromium SUID sandbox which is an executable that
-    Chromium may use in order to achieve sandboxing.
+  options.security.chromiumSuidSandbox.enable = mkOption {
+    type = types.bool;
+    default = false;
+    description = ''
+      Whether to install the Chromium SUID sandbox which is an executable that
+      Chromium may use in order to achieve sandboxing.
 
-    If you get the error "The SUID sandbox helper binary was found, but is not
-    configured correctly.", turning this on might help.
+      If you get the error "The SUID sandbox helper binary was found, but is not
+      configured correctly.", turning this on might help.
 
-    Also, if the URL chrome://sandbox tells you that "You are not adequately
-    sandboxed!", turning this on might resolve the issue.
+      Also, if the URL chrome://sandbox tells you that "You are not adequately
+      sandboxed!", turning this on might resolve the issue.
 
-    Finally, if you have <option>security.grsecurity</option> enabled and you
-    use Chromium, you probably need this.
-  '';
+      Finally, if you have <option>security.grsecurity</option> enabled and you
+      use Chromium, you probably need this.
+    '';
+  };
 
   config = mkIf cfg.enable {
     environment.systemPackages = [ sandbox ];