summary refs log tree commit diff
path: root/nixos/modules/security/apparmor.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-28 16:14:15 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-28 22:45:56 +0100
commitd5047faedef254d01a21618224698c190bb67e5b (patch)
tree42a43de15611b5e35b2888f02fb940365edb1402 /nixos/modules/security/apparmor.nix
parentf4a418761b481b15900c78b8086e7be58b0afe4e (diff)
downloadnixlib-d5047faedef254d01a21618224698c190bb67e5b.tar
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.gz
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.bz2
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.lz
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.xz
nixlib-d5047faedef254d01a21618224698c190bb67e5b.tar.zst
nixlib-d5047faedef254d01a21618224698c190bb67e5b.zip
Remove uses of the "merge" option attribute
It's redundant because you can (and should) specify an option type, or
an apply function.
Diffstat (limited to 'nixos/modules/security/apparmor.nix')
-rw-r--r--nixos/modules/security/apparmor.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/security/apparmor.nix b/nixos/modules/security/apparmor.nix
index d4aa0598dd3d..b9f151590028 100644
--- a/nixos/modules/security/apparmor.nix
+++ b/nixos/modules/security/apparmor.nix
@@ -15,6 +15,7 @@ with pkgs.lib;
     security.apparmor = {
 
       enable = mkOption {
+        type = types.bool;
         default = false;
         description = ''
           Enable AppArmor application security system. Enable only if
@@ -23,8 +24,8 @@ with pkgs.lib;
       };
 
       profiles = mkOption {
+        type = types.listOf types.path;
         default = [];
-        merge = mergeListOption;
         description = ''
           List of file names of AppArmor profiles.
         '';