summary refs log tree commit diff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorWilliButz <wbutz@cyberfnord.de>2018-03-09 21:33:09 +0100
committerWilliButz <wbutz@cyberfnord.de>2018-03-22 14:46:17 +0100
commitf4d03b5c9cf2b694792dec88e3ca805cf7b43e3c (patch)
tree3cb553f10849b086f3c15ad3de2dfc55243d31c8 /nixos/modules/rename.nix
parentf2bd9d4745041fe0c0a49803094dd625ebd27342 (diff)
downloadnixlib-f4d03b5c9cf2b694792dec88e3ca805cf7b43e3c.tar
nixlib-f4d03b5c9cf2b694792dec88e3ca805cf7b43e3c.tar.gz
nixlib-f4d03b5c9cf2b694792dec88e3ca805cf7b43e3c.tar.bz2
nixlib-f4d03b5c9cf2b694792dec88e3ca805cf7b43e3c.tar.lz
nixlib-f4d03b5c9cf2b694792dec88e3ca805cf7b43e3c.tar.xz
nixlib-f4d03b5c9cf2b694792dec88e3ca805cf7b43e3c.tar.zst
nixlib-f4d03b5c9cf2b694792dec88e3ca805cf7b43e3c.zip
nixos/prometheus-exporters: rewrite and restructure
- prometheus exporters are now configured with
  `services.prometheus.exporters.<name>`
- the exporters are now defined by attribute sets
  from which the options for each exporter are generated
- most of the exporter definitions are used unchanged,
  except for some changes that should't have any impact
  on the functionality.
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index 489d7d8b9b50..b0ca274b939f 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -240,5 +240,11 @@ with lib;
 
     # Xen
     (mkRenamedOptionModule [ "virtualisation" "xen" "qemu-package" ] [ "virtualisation" "xen" "package-qemu" ])
-  ];
+  ] ++ (flip map [ "blackboxExporter" "collectdExporter" "fritzboxExporter"
+                   "jsonExporter" "minioExporter" "nginxExporter" "nodeExporter"
+                   "snmpExporter" "unifiExporter" "varnishExporter" ]
+       (opt: mkRemovedOptionModule [ "services" "prometheus" "${opt}" ] ''
+         The prometheus exporters are now configured using `services.prometheus.exporters'.
+         See the 18.03 release notes for more information.
+       '' ));
 }