summary refs log tree commit diff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorzimbatm <zimbatm@zimbatm.com>2018-01-06 13:52:51 +0000
committerGitHub <noreply@github.com>2018-01-06 13:52:51 +0000
commiteddf30cc93e1b778b6bc10d0eb1bb175385d034f (patch)
treeb95f3a695c0794e674743e6551e47476a5b22ec6 /nixos/modules/rename.nix
parent51110e2a0fc9c415973b61adf09cd1dae16abff7 (diff)
downloadnixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.gz
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.bz2
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.lz
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.xz
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.tar.zst
nixlib-eddf30cc93e1b778b6bc10d0eb1bb175385d034f.zip
nixos: introduce boot.growPartition (#33521)
Move it from being a profile
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index 5e207a9509e2..562be13a3f64 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -186,6 +186,9 @@ with lib;
     (mkRenamedOptionModule [ "config" "fonts" "fontconfig" "ultimate" "forceAutohint" ] [ "config" "fonts" "fontconfig" "forceAutohint" ])
     (mkRenamedOptionModule [ "config" "fonts" "fontconfig" "ultimate" "renderMonoTTFAsBitmap" ] [ "config" "fonts" "fontconfig" "renderMonoTTFAsBitmap" ])
 
+    # Profile splitting
+    (mkRenamedOptionModule [ "virtualization" "growPartition" ] [ "boot" "growPartition" ])
+
     # Options that are obsolete and have no replacement.
     (mkRemovedOptionModule [ "boot" "initrd" "luks" "enable" ] "")
     (mkRemovedOptionModule [ "programs" "bash" "enable" ] "")